Closed Bug 986067 Opened 8 years ago Closed 8 years ago

Linker errors building on Windows with VS2010 and --disable-webrtc

Categories

(Firefox Build System :: General, defect)

x86_64
Windows 8.1
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 981780

People

(Reporter: TimAbraldes, Unassigned)

References

Details

I get the following linker errors when building on Windows with VS2010 and --disable-webrtc


33:49.11 Unified_cpp_content_media_encoder0.obj : error LNK2019: unresolved external symbol I422ToI420 referenced in function "private: enum tag_nsresult __cdecl mozilla::VP8TrackEncoder::PrepareRawFrame(struct mozilla::VideoChunk &)" (?PrepareRawFrame@VP8TrackEncoder@mozilla@@AEAA?AW4tag_nsresult@@AEAUVideoChunk@2@@Z)

33:49.11
33:49.11 Unified_cpp_content_media_encoder0.obj : error LNK2019: unresolved external symbol I444ToI420 referenced in function "private: enum tag_nsresult __cdecl mozilla::VP8TrackEncoder::PrepareRawFrame(struct mozilla::VideoChunk &)" (?PrepareRawFrame@VP8TrackEncoder@mozilla@@AEAA?AW4tag_nsresult@@AEAUVideoChunk@2@@Z)

33:49.11
33:49.11 Unified_cpp_content_media_encoder0.obj : error LNK2019: unresolved external symbol NV21ToI420 referenced in function "private: enum tag_nsresult __cdecl mozilla::VP8TrackEncoder::PrepareRawFrame(struct mozilla::VideoChunk &)" (?PrepareRawFrame@VP8TrackEncoder@mozilla@@AEAA?AW4tag_nsresult@@AEAUVideoChunk@2@@Z)

33:49.11
33:49.11 Unified_cpp_content_media_encoder0.obj : error LNK2019: unresolved external symbol NV12ToI420 referenced in function "private: enum tag_nsresult __cdecl mozilla::VP8TrackEncoder::PrepareRawFrame(struct mozilla::VideoChunk &)" (?PrepareRawFrame@VP8TrackEncoder@mozilla@@AEAA?AW4tag_nsresult@@AEAUVideoChunk@2@@Z)


This bug seems similar to bug 981780 and seems like it was introduced by the patch in bug 970787.

I'm currently building without --disable-webrtc to verify that the problem goes away without that flag.
Yes, this is a known problem and basically a dup of bug 981780; I suggest dupping it against that
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 981780
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.