Closed Bug 986094 Opened 6 years ago Closed 4 years ago

crash in __sync_fetch_and_sub_4

Categories

(Core :: Graphics: Layers, defect, critical)

30 Branch
ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: tnguyen, Unassigned)

References

()

Details

(Keywords: crash, regression, Whiteboard: dogfood1.4, [b2g-crash])

Crash Data

Attachments

(1 file)

22.59 KB, text/plain
Details
This bug was filed from the Socorro interface and is 
report bp-20578ed3-6a1e-47c5-8a2a-a3cae2140320.
=============================================================

The crash occurred when viewing a video on Daily Motion, turning the device to landscape mode and then tapping the home button. The device crashed shortly after. 

Repro Steps:
1) Updated Buri to BuildID: 20140320000349
2) Navigate to Browser app
3) Navigate to www.dailymotion.com
4) Tap on any video > Fullscreen the video
5) Tap on the video while in fullscreen
6) Turn the device to landscape mode
7) Tap the home button to return home

Actual Result:
Device crashes

Expected Result: 
Device doesn't crash 

Environmental Variables:
Device: Buri v1.4 mozRIL
BuildID: 20140320000349
Gaia: 53edbf08b0a750c31e8c6b2c20f2b1315b1412d1
Gecko: 9b482d6994fd
Version: 30.0a2
v1.2-device.cfg

Repro Frequency: 1/5 - I was only able to reproduce this issue once, but will attempt to get better STR and update this bug.

Note: There are no video options when viewing a video in fullscreen on Daily Motion. The user is therefore also unable to exit fullscreen and can only do so by tapping the home button. 

URL: http://youtu.be/zbNRh3Lk8q4
Whiteboard: dogfood1.4
Whiteboard: dogfood1.4 → dogfood1.4, [b2g-crash]
The crash stack heavily hints at this being a regression from bug 946720.
Blocks: 946720
Component: Gaia::Browser → Graphics: Layers
Keywords: regression
Product: Firefox OS → Core
Version: unspecified → 30 Branch
Leaving needinfo on you to nail down reproducible STR.
Flags: needinfo?(tnguyen)
Attached file logcat
I've been unable to reproduce this issue after multiple attempts. The device seems to lag a bit after returning to the homescreen by tapping on the home button, but it does not crash. I'll attach a logcat showing what happens while running through the same STR.
Flags: needinfo?(tnguyen)
Flags: needinfo?(nhirata.bugzilla)
I can't reproduce this crash either on the 1.4:
Gaia      4c3b2f57f4229c5f36f0d8fd399e65f4db88f104
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/3aaca223b673
BuildID   20140331000202
Version   30.0a2
ro.build.version.incremental=324
ro.build.date=Thu Dec 19 14:04:55 CST 2013
Buri
Flags: needinfo?(nhirata.bugzilla)
Mass resolving WFM: signature(s) hasn't(/haven't) reported in past 28 days.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.