Closed Bug 986173 Opened 7 years ago Closed 7 years ago

Intermittent TEST-UNEXPECTED-FAIL | Dialer > Keypad Entering a 3 digits number with the keypad | AssertionError: you need more than 16 reflows for that?

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: RyanVM, Assigned: janx)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=36439132&tree=Fx-Team

b2g_ubuntu64_vm fx-team opt test gaia-integration on 2014-03-20 05:11:20 PDT for push d0f486cca94e
slave: tst-linux64-spot-587

05:25:44     INFO -  TEST-START | Dialer > Keypad Entering a 3 digits number with the keypad
05:25:53     INFO -  TEST-UNEXPECTED-FAIL | Dialer > Keypad Entering a 3 digits number with the keypad
05:25:53     INFO -  TEST-END | Dialer > Keypad Entering a 3 digits number with the keypad

05:49:11     INFO -    1 failing
05:49:11     INFO -    1) Dialer > Keypad Entering a 3 digits number with the keypad:
05:49:11     INFO -    AssertionError: you need more than 16 reflows for that?
05:49:11     INFO -        at Context.<anonymous> (/builds/slave/test/gaia/apps/communications/dialer/test/marionette/keypad_test.js:66:12)
05:49:11     INFO -        at Test.Runnable.run (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:211:32)
05:49:11     INFO -        at Runner.runTest (/builds/slave/test/gaia/node_modules/mocha/lib/runner.js:372:10)
05:49:11     INFO -        at /builds/slave/test/gaia/node_modules/mocha/lib/runner.js:448:12
05:49:11     INFO -        at next (/builds/slave/test/gaia/node_modules/mocha/lib/runner.js:297:14)
05:49:11     INFO -        at /builds/slave/test/gaia/node_modules/mocha/lib/runner.js:307:7
05:49:11     INFO -        at next (/builds/slave/test/gaia/node_modules/mocha/lib/runner.js:245:23)
05:49:11     INFO -        at /builds/slave/test/gaia/node_modules/mocha/lib/runner.js:269:7
05:49:11     INFO -        at Hook.Runnable.run (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:213:5)
05:49:11     INFO -        at next (/builds/slave/test/gaia/node_modules/mocha/lib/runner.js:257:10)
05:49:11     INFO -        at /builds/slave/test/gaia/node_modules/mocha/lib/runner.js:269:7
05:49:11     INFO -        at done (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:185:5)
05:49:11     INFO -        at /builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:197:9
05:49:11     INFO -        at Object.executeHook (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:370:18)
05:49:11     INFO -        at process._tickCallback (node.js:415:13)
Testing locally, I get "AssertionError: 0 == 16" so it looks like something in https://hg.mozilla.org/mozilla-central/pushloghtml?startID=26485&endID=26486 broke the reflow counter tool.

Jan: Anything suspect in this pushlog?
Flags: needinfo?(janx)
seems this causing Gaia Integration test failures in m-i,m-c and b2g-inbound - closing at least b2g-i for this test bustage and hope that the backout from 

remote:   https://hg.mozilla.org/mozilla-central/rev/4b412c6dbffc
remote:   https://hg.mozilla.org/mozilla-central/rev/9d62c16eefde
remote:   https://hg.mozilla.org/mozilla-central/rev/9afe2a1145bd

fix anything
The push log has several devtools changes that talk about reflows but are unrelated.

My patch from bug #983610 did some important changes to the way the HUD tracks frames. Let's see if Carsten's backout fixes things.

Also I couldn't find which test is failing, Etienne is that your ReflowHelper / MozReflowAtom test that was changed and uplifted in bug #982196? Could it be that we expect 0 reflows from the dialer but suddenly see 16 reflows happening?

I'll try reproducing locally to make more sense of this.
Flags: needinfo?(janx) → needinfo?(etienne)
It's that test but the problem here is that we're expecting 16 reflows but got 0.

How to run the test:
TEST_FILES=./apps/communications/dialer/test/marionette/keypad_test.js make test-integration
Docs: https://developer.mozilla.org/en-US/Firefox_OS/Platform/Automated_testing/Gaia_integration_tests

To get the error message I'm seeing, replace:
    assert.equal(reflowCount, 16, 'you need more than 16 reflows for that?');
with:
    assert.equal(reflowCount, 16);
seems this backout of the 3 patches fixed this problem
I disabled the test in https://github.com/mozilla-b2g/gaia/commit/c9c87f5d1aa8ddfe4fe2a1742d97c3c5a453fab0 because fx-team is read right now.

Jan: Can you also check why?
Flags: needinfo?(janx)
This time it started on this push:
https://tbpl.mozilla.org/?tree=Fx-Team&rev=b086a61f4cfc

Seems the common thread is "something touches devtools which perturbs this test into failing".
For later reference, I'm just disabling this to get a green tree today and so that Jan can check why it broke. Once we know why it broke, I think we should have test on the devtools side to prevent breaking this very useful test.
I found that bug #983610's patch breaks that particular test, so I'm investigating why reflow reporting works everywhere else except in the test. I'll get back to this bug once I find out what's wrong.
Flags: needinfo?(janx)
Depends on: 988931
I opened a pull request to reenable the test now that bug #988931's fix has rolled. Let's see how travis takes it.
Comment on attachment 8398432 [details] [review]
Bug 986173 - Reenable the dialer reflow test. r=Rik

All green!
Attachment #8398432 - Flags: review?(anthony)
Comment on attachment 8398432 [details] [review]
Bug 986173 - Reenable the dialer reflow test. r=Rik

Rik's r+ IRL if I can stay around to watch travis and tbpl.
Attachment #8398432 - Flags: review?(anthony) → review+
The travis build had two unrelated fails, but the re-enabled test passed: https://travis-ci.org/mozilla-b2g/gaia/jobs/21923061#L2663
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Assignee: nobody → janx
OS: Linux → All
Hardware: x86_64 → All
You need to log in before you can comment on or make changes to this bug.