Closed Bug 986423 Opened 9 years ago Closed 9 years ago

Invisible animated gif activates the refresh driver

Categories

(Core :: Graphics: ImageLib, defect)

28 Branch
x86
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 968123

People

(Reporter: rvitillo, Unassigned)

References

()

Details

(Keywords: power)

Attachments

(1 file)

FF has an high power usage on alipay as seen on the URL.
Attached file Testcase 1
Yet another invisible spinning wheel activating the refresh driver.
Component: General → CSS Parsing and Computation
Product: Firefox → Core
Summary: High power consumption on alipay. → Invisible animated gif (in 'display:none' subtree) activates the refresh driver
I was pretty sure we have an existing bug on this, but I can't find it...
Component: CSS Parsing and Computation → ImageLib
Maybe you had in mind Bug 962594?
No, I was thinking about animated gifs specifically.  I could also just be misremembering!
Hmm, looking at the code in nsImageLoadingContent I'm not sure how an animated image that never has a frame can get registered with the refresh driver.
(In reply to Timothy Nikkel (:tn) from comment #5)
> Hmm, looking at the code in nsImageLoadingContent I'm not sure how an
> animated image that never has a frame can get registered with the refresh
> driver.

After retrying with a clean profile with the latest Nightly the refresh driver doesn't get activated. Either this bug got fixed after the current release or something in my configuration skewed the power metrics.
Okay, thanks for re-testing. It's possible if maybe the same image was used in the same session (when it did get a frame) that maybe it didn't unhooked from the refresh driver? Toggling from display: something to display: none perhaps? Although that should work properly given the current code.
Summary: Invisible animated gif (in 'display:none' subtree) activates the refresh driver → Invisible animated gif activates the refresh driver
It seems that the real issue on that website comes from a covered background gif. The spinning wheel in the display:none subtree doesn't activate the refresh driver by itself. I am not quite sure how it did in the first place, I will keep digging.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 968123
You need to log in before you can comment on or make changes to this bug.