Closed Bug 986534 Opened 11 years ago Closed 10 years ago

HTTP cache v2: Perma-failure TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/beacon/test_beaconFrame.html | Beacon status should match expected. is: hi! should be: 123 - got hi!, expected 123

Categories

(Core :: Networking: Cache, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla31

People

(Reporter: mayhemer, Assigned: mayhemer)

References

Details

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=36472264&tree=Try

This is a perma failure with the new HTTP cache v2.
See Also: → 984561
As in many other cases the test is wrong.  It assumes we send out requests in the same order as they've been programmatically invoked.  That is a bad assumption.  The handler must block GET until the POST arrives.  I'll try to fix it.
Attached patch v1Splinter Review
Inspired by https://bugzilla.mozilla.org/page.cgi?id=splinter.html&bug=957243&attachment=8365249 from bz.
Assignee: nobody → honzab.moz
Status: NEW → ASSIGNED
Attachment #8394903 - Flags: review?(rlb)
Comment on attachment 8394903 [details] [diff] [review]
v1

Review of attachment 8394903 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.  Sorry for the delay.
Attachment #8394903 - Flags: review?(rlb) → review+
https://hg.mozilla.org/mozilla-central/rev/2c3cfac2de70
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: