Last Comment Bug 986621 - GPS is no longer work after an update to FirefoxOS 1.2 on ZTE Open
: GPS is no longer work after an update to FirefoxOS 1.2 on ZTE Open
Status: UNCONFIRMED
:
Product: Firefox OS
Classification: Client Software
Component: Gaia (show other bugs)
: unspecified
: All All
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-21 12:37 PDT by lordphoenix
Modified: 2014-06-21 23:04 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
gps.conf.mozilla (see https://bugzilla.mozilla.org/show_bug.cgi?id=955880) (1.05 KB, text/plain)
2014-03-25 11:54 PDT, Paul Wolneykien
no flags Details
gps.conf.mozilla (see http://www.modaco.com/topic/351968-satelite-fix-for-gps/) (1.05 KB, text/plain)
2014-03-25 11:55 PDT, Paul Wolneykien
no flags Details
user.js.gps.google (see https://bugzilla.mozilla.org/show_bug.cgi?id=955880) (16.71 KB, text/plain)
2014-03-25 11:56 PDT, Paul Wolneykien
no flags Details
SuplRootCert (Equifax Secure Certificate Authority) (804 bytes, application/octet-stream)
2014-03-25 11:56 PDT, Paul Wolneykien
no flags Details
gps.conf.google (see http://www.modaco.com/topic/351968-satelite-fix-for-gps/) (1.38 KB, text/plain)
2014-03-25 11:57 PDT, Paul Wolneykien
no flags Details

Description User image lordphoenix 2014-03-21 12:37:08 PDT
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20140317233339

Steps to reproduce:

I've updated my Zte Open with FirefoxOS 1.2 following instructions in this page https://developer.mozilla.org/en-US/Firefox_OS/Developer_phone_guide/ZTE_OPEN


Actual results:

Any application who need GPS can get my position. I've made test with applications : Geoloc, Here maps, Google maps and any of them get gps information.
Comment 1 User image Paul Wolneykien 2014-03-24 02:39:55 PDT
Do you mean 'expected results' instead of 'actual'? I've just found that all GPS apps don't work any more after the upgrade. Some of the apps (i.e. GPS-Dashboard and Speed) shows that there is "no GPS signal".
Comment 2 User image lordphoenix 2014-03-24 09:10:08 PDT
Sorry it's because of my bad englih… I mean that all GPS apps I've tried don't work…
Comment 3 User image Paul Wolneykien 2014-03-25 11:54:22 PDT
Created attachment 8396606 [details]
gps.conf.mozilla (see https://bugzilla.mozilla.org/show_bug.cgi?id=955880)
Comment 4 User image Paul Wolneykien 2014-03-25 11:55:24 PDT
Created attachment 8396608 [details]
gps.conf.mozilla (see http://www.modaco.com/topic/351968-satelite-fix-for-gps/)
Comment 5 User image Paul Wolneykien 2014-03-25 11:56:11 PDT
Created attachment 8396609 [details]
user.js.gps.google (see https://bugzilla.mozilla.org/show_bug.cgi?id=955880)
Comment 6 User image Paul Wolneykien 2014-03-25 11:56:37 PDT
Created attachment 8396610 [details]
SuplRootCert (Equifax Secure Certificate Authority)
Comment 7 User image Paul Wolneykien 2014-03-25 11:57:49 PDT
Created attachment 8396614 [details]
gps.conf.google (see http://www.modaco.com/topic/351968-satelite-fix-for-gps/)
Comment 8 User image Paul Wolneykien 2014-03-25 12:10:36 PDT
I've tested a number of GPS configuration files on my ZTE Open and finished with these ones: see the attachments above. Both gps.conf.mozilla (from the discussion of #955880) and gps.conf.google (for another ZTE phone, I guess) work for me.


You need to:

1. take one or an other gps.conf.* file and setup the NTP servers for your region and country -- in my case that are "europe" and "ru" (it might be that simple "pool.ntp.org" works too, I didn't test that case);

2. adb shell mount -o remount,rw /; adb shell mount -o remount,rw /system;

3. adb push gps.conf.<yourchoice> /etc/gps.conf;

4. adb push gps.conf.<yourchoice> /system/etc/gps.conf;

5. take your current user.js file -- adb pull /system/b2g/defaults/pref/user.js ./;

6. edit it -- setup the geo.gps.* settings as in the attachment;

7. push it back -- adb push user.js /system/b2g/defaults/pref/user.js;

8. adb push SuplRootCert /etc/SuplRootCert;

9. adb push SuplRootCert /system/etc/SuplRootCert.

10. adb shell reboot.


After that GPS works for me in Speed, GPS Dashboard and HERE Maps.
Comment 9 User image pavithran.s 2014-06-21 23:04:01 PDT
Thank you @paul  . That solution you posted above worked for me , I was able to extract a GPS track with the run recorder app.

Note You need to log in before you can comment on or make changes to this bug.