Closed Bug 986693 Opened 6 years ago Closed 6 years ago

Feature Request: Dev Tools Console right click a network request and go to network panel details

Categories

(DevTools :: Console, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 861335

People

(Reporter: austinlhammer, Unassigned)

Details

(Keywords: feature)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140318013849

Steps to reproduce:

Open up the console, check "network", load a page, or wait for an XHR/AJAX request to happen, and right click it. The current options are "Log Requests", "Open URL in New Tab", "Copy Link Location", etc.

I propose the ability to "View Request Details" which will open the request in the Network panel, as well as the right-panel for details. Right now you can click on a request in the console tab and it opens up a mini version of this called "Inspect Network Request". 

However, the problem with this mini-popup is that you cannot edit/resend the response, header information is unreadable compared to network panel, and you cannot view the response easily either: Not to mention the new "render HTML" that's recently been added is unusable for requests caught by the console. Timing information would also be nice, although that is not nearly as important as being able to quickly catch a request and resend it for debugging. 

There is a disconnect/duplication between the network request console logging and the network panel and I think this gap should be closed/simplified.
Component: Untriaged → Developer Tools: Console
Keywords: feature
Thanks for the feature request.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 861335
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.