Home page pref ignored; loads Netscape 6 ad on startup instead

VERIFIED INVALID

Status

VERIFIED INVALID
17 years ago
14 years ago

People

(Reporter: blahedo, Assigned: samir_bugzilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
The last couple of nightlies completely ignore my "start up with my home page"
preference, instead loading http://home.netscape.com/browsers/6/su_setup.html,
which annoyingly resizes my window to much smaller than I want it to be.

Reproduceability: upon new download, I think.  When I first download a new build
and run it, it does this on every startup, but if I go to Preferences and force
it to re-save my home page pref, further startups work correctly.
Reporter: 
Does it work if you install the new nightly, run it (goes to a different 
homepage) and then close mozilla and run it again ?
(Reporter)

Comment 2

17 years ago
It did indeed---I quit mozilla and restarted it several times, each time greeted
by the netscape 6 ad, before I fixed it by re-saving my prefs.  I can't
reproduce it right now, because it doesn't seem to occur with earlier version
numbers, and the latest download doesn't launch for me at all (but that's for
another bug report, I suppose).
(Reporter)

Comment 3

17 years ago
I should note, though, that the re-saving thing doesn't seem to be permanent,
because I "fixed" the problem when I ran 2001-09-05-08, and I had to re-"fix" it
for 2001-09-06-08.  I hypothesise that if I had a newer build available to me
it'd recur there, too.
What I mean:
We have a new feature that Mozilla/NS loads a different Homepage the first you 
run a new build (different UA String/overrides User pref). -> bug 97220
But Mozilla should load your Homepage if you run mozilla the second time.
This is a feature and not a bug. 
This is a Bug if NS goes to the NS page at the second time you run NS.

-> Installer 
Assignee: asa → sgehani
Component: Browser-General → Installer
QA Contact: doronr → gemal
(Assignee)

Comment 5

17 years ago
You may have used Netscape 6.x with the same profile causing a
"startup.homepage_override_url" pref to be written to your profile's prefs.js
file.  Since user prefs take precedence over factory defaults this is where your
mozilla nightlies are taking you when a milestone change was observed.  Remove
the said pref from your prefs.js when the browser is not running and then try
again.  

If you go back and forth between milestones you will see the behavior that the
URL from the said pref will be shown once for the build the first time you
launch it after installing it.  On subsequent runs it should revert to your
homepage.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Why would the startup URL itself have been written to the profile prefs?
Shouldn't this be in all-ns.js or a Netscape-ized properties file or something?  

mozilla.org may very well want to use the same feature for its milestones (to
point at the release notes?)
(Reporter)

Comment 7

17 years ago
Matti said: "This is a Bug if NS goes to the NS page at the second time you run
NS."  It did; you'll note that I said, "I quit mozilla and restarted it several
times".

He also said "This is a feature and not a bug."  I'd disagree, since I don't
really want to look at advertising every time I dl a new version, especially if
I'm doing that several times a week.

But ultimately, it fails to matter.  In the latest build (09-10-08) it didn't
pop up the netscape ad or any other thing (not even the first time).  So I'm
happy. :)

Comment 8

17 years ago
verified
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → gbush
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.