Mozilla doesn't obey Start/End Navigation prefs in Sounds control panel (click sounds)

NEW
Unassigned

Status

defect
--
minor
18 years ago
2 years ago

People

(Reporter: mpt, Unassigned)

Tracking

(Depends on 1 bug, Blocks 1 bug, {platform-parity})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
To reproduce:
1.  Start Mozilla.
2.  Open the Sounds and Multimedia control panel.
3.  From the `Events' listbox, choose `Start Navigation'.
4.  Set the sound for this event to C:\Windows\Media\start.wav (or the
    equivalent path on your machine).
5.  Repeat steps 3 and 4, but with `Complete Navigation' and
    C:\Windows\Media\Utopia Open.wav or equivalent.
6.  Click OK.
7.  In Mozilla, click on a link -- or click the Back, Forward, or Reload
    buttons.

What should happen:
*   You hear a `click' noise.
*   Mozilla connects to the server if necessary.
*   You hear a short whirring noise.
*   The page begins to display.

What currently happens (I assume):
*   Mozilla connects to the server if necessary.
*   The page begins to display.
*   You hear no noises at all.
(Reporter)

Updated

18 years ago
Keywords: pp
Summary: Mozilla doesn't obey Start/End Navigation prefs in Sounds control panel → Mozilla doesn't obey Start/End Navigation prefs in Sounds control panel (click sounds)
(Reporter)

Updated

18 years ago
Blocks: 98474

Comment 1

18 years ago
Those are for Windows Explorer.  resolving as invalid.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
mass verification of Invalid bugs: to find all bugspam pertaining to this,
set your search string to "MagaritaLuisaChascarilloAvoidsInvalidBugs".

if you think this particular bug is *still* an open issue, please make sure of
the following before reopening:

a. where relevant, do check that it's actually still a problem with ***recent
trunk builds*** on the all appropriate platform[s]

b. provide clear, compelling reasons why this bug should be considered a valid one.
Status: RESOLVED → VERIFIED

Comment 3

17 years ago
humm, re-opening. this should be given more thought.

those sounds arn't only for windows, any win application is free to use them.
such as the eudora mail client, or (i think) aol messenger. which creates it's
own section. so why not moz?

since the windows port of moz is actually a windows application, it should obey
the laws the user has set.

such as these (it already does): -
- the size of the icons;
- the size of the title bar;
- changing font sizes affects moz's windows.
- etc.

so why not obey sounds?
this would also help people with accessibility.

... hey, even the moz's mail client could have it's own defined sounds in that
multimedia panel. also, having sounds in moz would make some people realise
mozilla is more friendly than they realise.. just like adding smooth scrolling.

this should be given greater thought, re-opening.
Status: VERIFIED → REOPENED
Resolution: INVALID → ---

Comment 4

16 years ago
See also bug 83056.

Comment 5

16 years ago
Reassinging bug to default owner
Assignee: paulkchen → jag
Status: REOPENED → NEW
QA Contact: sairuh → pawyskoczka
Product: Core → Mozilla Application Suite

Comment 6

14 years ago
Related but on the opposite end of things, I don't consider programs having
"sound" "friendly": beeps and other nonsense annoy the hell out of me.  I want
Firefox to respect MY Control panel | Sounds options, too; mine are set to "no
sounds", but Firefox continues to give me an annoying beep every time I search
past the end of a file (i.e., no more occurrences of a search term are found in
the document).

P.S. - I do NOT want to mute the speaker, because if I want to play a CD or
something, the speakers/volume control needs to stay enabled.  I just wish (as
did the original submitter) that Firefox would respect my Windows (XP Pro)
settings RE: what programs are allowed to do RE: sounds.

Thanks for listening!

Aloha,
philiptdotcom
I posted the test builds of Fx (trunk) to bug 248380. If you can test it, see bug 248380 comment 16. I need your feedback, thank you.

Comment 9

6 years ago
Is this still an issue?
Assignee: jag-mozilla → nobody
You need to log in before you can comment on or make changes to this bug.