Intermittent browser_UITour3.js | Test timed out, or, This test exceeded the timeout threshold. It should be rewritten or split up.

RESOLVED FIXED

Status

()

defect
P3
normal
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: philor, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86
Linux
Points:
---
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox29 disabled, firefox30 disabled, firefox31 disabled, firefox-esr24 unaffected)

Details

https://tbpl.mozilla.org/php/getParsedLog.php?id=36532004&tree=Mozilla-Inbound
Rev3 Fedora 12x64 mozilla-inbound debug test mochitest-browser-chrome on 2014-03-21 14:57:12 PDT for push 2b638fb2d8fc
slave: talos-r3-fed64-062

16:46:12  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/modules/test/browser_UITour3.js | This test exceeded the timeout threshold. It should be rewritten or split up. If that's not possible, use requestLongerTimeout(N), but only as a last resort.
16:46:12     INFO -  TEST-INFO | MEMORY STAT vsize after test: 3767287808
16:46:12     INFO -  TEST-INFO | MEMORY STAT residentFast after test: 1314942976
16:46:12     INFO -  INFO TEST-END | chrome://mochitests/content/browser/browser/modules/test/browser_UITour3.js | finished in 36705ms
Matt, can you take a look at this please? It's happy extremely often, even by mochitest-bc standards.
Flags: needinfo?(MattN+bmo)
Comment 28 and 30 seem different to me. Here is one of the screenshots: http://mozilla-releng-blobs.s3.amazonaws.com/blobs/mozilla-inbound/sha512/7236626f104dcfae0f31bab6bae94eeafbf12e93977f748dbaf0911cc0d11ea16ea34f8903ab5011229e672058417b3d583adb797e01379e4192eee01c9e6597 
It appears after a "must wait for focus" and seems like a variation of bug 565437. I don't see myself working on this soon since it's only seen 30 failures in 6 days and it's likely a focus/platform issue that I won't be able to do much about.
Only difference between timed-out and timeout-threshold is how long it had been since your last output, so I presume they're the same root cause. Time will tell.
Summary: Intermittent browser_UITour3.js | This test exceeded the timeout threshold. It should be rewritten or split up. → Intermittent browser_UITour3.js | Test timed out, or, This test exceeded the timeout threshold. It should be rewritten or split up.
Comment 83 which happened on inbound is on the revision before this push...
Comment 91, however...
(In reply to Phil Ringnalda (:philor) from comment #92)
> Comment 91, however...

Hmm, yeah..  I'm not sure if I have any other ideas.  Looking at the screenshot on comment 91's log, it definitely shows that the Firefox window is not focused.  Neil, this is another bug where waitForFocus fails to restore focus to the Firefox window.
Flags: needinfo?(enndeakin)
(In reply to Matthew N. [:MattN] from comment #33)
> 565437. I don't see myself working on this soon since it's only seen 30
> failures in 6 days and it's likely a focus/platform issue that I won't be
> able to do much about.

Justin, this is currently the #1 orange on trunk. If Matt doesn't have time to look into this, can you suggest someone who does so I don't have to resort to disabling the test instead?
Flags: needinfo?(dolske)
Disabled on Linux in https://hg.mozilla.org/integration/fx-team/rev/421159f3d1e8
Whiteboard: [test disabled on Linux]
when this is run in chunks, we leak a docshell window for all windows platforms on debug:
https://tbpl.mozilla.org/php/getParsedLog.php?id=37306049&tree=Cedar#error0
I think disabling these until after we ship Australis in 29 is fine. Matt should be able to take a look then.
Flags: needinfo?(dolske)
I think Enn is the right person to at least give a theory on this.

(In reply to Joel Maher (:jmaher) from comment #215)
> when this is run in chunks, we leak a docshell window for all windows
> platforms on debug:
> https://tbpl.mozilla.org/php/getParsedLog.php?id=37306049&tree=Cedar#error0

If I'm reading that correctly, this is the speculative connection leak that I already fixed in bug 992611.
Flags: needinfo?(MattN+bmo) → firefox-backlog?
Flags: firefox-backlog? → firefox-backlog+
Moving open UITour bugs to Firefox::Tours. Filter on firefox-tours-20150121.
Component: General → Tours
Flags: needinfo?(enndeakin)
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 2 years ago
Keywords: leave-open
Resolution: --- → FIXED
Whiteboard: [test disabled on Linux]
You need to log in before you can comment on or make changes to this bug.