Closed Bug 986784 Opened 7 years ago Closed 7 years ago

Menu button icon looks like it is higher in the toolbar than other buttons

Categories

(Firefox :: Toolbars and Customization, defect)

30 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: aks, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P4+])

Attachments

(1 file, 2 obsolete files)

Attached image Aurora 30 (obsolete) —
The toolbar icons after the Aurora 30 update have a size discrepancy. 
This discrepancy was not present in Aurora 29.
Attached image Aurora 29 (obsolete) —
Does this happen with a clean profile?
Flags: needinfo?(aksht.kedia)
No I am not able to reproduce the bug in a clean profile. Although the menu button does look a bit misaligned from the rest don't you think so ?
Flags: needinfo?(aksht.kedia) → needinfo?(gijskruitbosch+bugs)
Attached image Aurora 30 Clean.JPG
I actually kind of agree, and looking at the DOM structure, the icon is exactly at the same y-position as the icon of e.g. the home button, and the exact same size. Looking at the sprite sheet, it seems like the button is positioned slightly higher. Stephen, is that just me?
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(shorlander)
Whiteboard: [Australis:P4+]
Summary: Toolbar icons have a size discrepancy → [OS X] Menu button icon looks like it is higher in the toolbar than other buttons
(In reply to :Gijs Kruitbosch from comment #5)
> I actually kind of agree, and looking at the DOM structure, the icon is
> exactly at the same y-position as the icon of e.g. the home button, and the
> exact same size. Looking at the sprite sheet, it seems like the button is
> positioned slightly higher. Stephen, is that just me?

If we are referring to the way it is supposed to look by default, then yes it is 1px higher in the canvas than the other icons because it has an odd sized height.

The problem shown attachment 8395155 [details] looks to be caused by the navBar being taller stretched and the menu button stretching with it.
Flags: needinfo?(shorlander)
(In reply to Stephen Horlander [:shorlander] from comment #6)
> The problem shown attachment 8395155 [details] looks to be caused by the
> navBar being taller stretched and the menu button stretching with it.

In this case it doesn't make sense that the icons are both displayed at the same y coordinates, though (which is certainly what DOMI says). Please ignore the attachment you referenced and instead look at attachment 8395266 [details]. :-)
Flags: needinfo?(shorlander)
Attachment #8395155 - Attachment is obsolete: true
Attachment #8395157 - Attachment is obsolete: true
Summary: [OS X] Menu button icon looks like it is higher in the toolbar than other buttons → Menu button icon looks like it is higher in the toolbar than other buttons
(In reply to :Gijs Kruitbosch from comment #7)
> (In reply to Stephen Horlander [:shorlander] from comment #6)
> > The problem shown attachment 8395155 [details] looks to be caused by the
> > navBar being taller stretched and the menu button stretching with it.
> 
> In this case it doesn't make sense that the icons are both displayed at the
> same y coordinates, though (which is certainly what DOMI says). Please
> ignore the attachment you referenced and instead look at attachment 8395266 [details]
> [details]. :-)

Yes, it's 1px higher visually than the other icons because it has an odd height. i.e. there is no way to vertically center it without changing the height of the icon.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(shorlander)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.