DOM uses nsString::GetUnicode(), which is no longer exists

RESOLVED DUPLICATE of bug 119680

Status

RESOLVED DUPLICATE of bug 119680
17 years ago
6 years ago

People

(Reporter: ovk, Assigned: ashuk)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Compiler exits with following error:

nsJavaDOMImpl.cpp(635) : error C2039: 'GetUnicode' : is not a member of 
'nsString' ..\..\..\dist\include\nsString2.h(72) : see declaration of 'nsString'

WinNT 4 with SP4.
Mozilla source from Sep 6 2001.
(Reporter)

Comment 1

17 years ago
Created attachment 48553 [details] [diff] [review]
Possible fix
Won't those places where you did not add calls to free() leak?

Is there a reason not to use nsString::get() ?

Comment 3

14 years ago
Oleg, Boris,
Any progress on this one?
Thomas, I'm not working on this bug.  If someone writes up a patch I can help
get it reviewed and checked in, though...
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 119680
Component: Java APIs for DOM → Java APIs for DOM
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.