embedded table result in bad layout

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: lode leroy, Assigned: karnaze (gone))

Tracking

Trunk
Future
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080110

3 tables are put in a table cell which has a width that
would force them to be laid out under each other, 
but the 2nd and 3rd are put next to one another,
causing the display width to be wider than the cell width

Reproducible: Always
Steps to Reproduce:
1.visit the url
2.
3.

Actual Results:  The navigation column on the left side contains three tables,
and the TD that contains it is just wide enough to show
them one under another (in IE and NN). However Mozilla 
displays the 3rd table that contains only an empty paragraph
next to the 2nd one, making the left navigation column too wide,
causing the image on the right of the page to be cropped.

Expected Results:  all tables under one another


My guess is that while laying out the page, the table is considered to be 0
pixels wide, but when drawing it, the table width="101" is taken
into account...

(It has to do with the "quirks mode" , since adding the doctype in a copy of the
page solves the issue)

Comment 1

16 years ago
I am getting the bad layout too on build 2001090703 on winME

Comment 2

16 years ago
Linux 20010907 build, I see problems with the page as well. The text of the body
is partially overlaying the right border.

Comment 3

16 years ago
Table issue? I cannot tell but it sounds like it - over to karnaze for his quick
analysis. Send it back if you think it is block muckin' it up (isn't it always?)
Assignee: attinasi → karnaze

Comment 4

16 years ago
This page has some layout problem on the far right column where the stock table
and vertical banner ads are cropped. Need to create a test case.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 5

16 years ago
Temporarily moving to future until a milestone can be assigned. 
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 6

16 years ago
I don't know.  The given page in the URL bar seems to lay out great.  It looks 
the same in IE as well (using todays build on winNT).  I also do not see the 
above metnioned stock problem.

I'm gonna mark this one WORKSFORME.

Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.