Closed Bug 986868 Opened 7 years ago Closed 2 years ago

During the customization mode transition you should not be able to click/hover items in the toolbars

Categories

(Firefox :: Toolbars and Customization, defect)

31 Branch
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ntim, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: steps-wanted, Whiteboard: [qx:spec])

Attachments

(1 file)

It's a bit weird to be able to click the customization mode items during transition.
You can even make panels pop up during the transition.
Mentor: gijskruitbosch+bugs
Whiteboard: [Australis:P-] → [qx][good first bug][lang=css]
I don't even think this bug is still current. Also, if you're going to mark me as a mentor, please at least CC me so I get bugmail, and if you're not going to give any indication of how to fix the bug, you should needinfo me so I can provide some. More generally, I'd prefer that you don't just randomly assign me as a mentor without discussing this first. :-\
Whiteboard: [qx][good first bug][lang=css]
This looks like it was fixed by bug 961848, so resolving dupe.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(ntim007)
Resolution: --- → DUPLICATE
Whiteboard: [qx]
Duplicate of bug: 961848
This still doesn't seem fixed.
Status: RESOLVED → REOPENED
Flags: needinfo?(ntim007)
Resolution: DUPLICATE → ---
(In reply to :Gijs Kruitbosch from comment #2)
> More generally, I'd prefer that you don't just
> randomly assign me as a mentor without discussing this first. :-\

This is true of anyone -- all mentors should be volunteering (or at least asked to volunteer), not blindly assigned.
(In reply to Tim Nguyen [:ntim] from comment #4)
> This still doesn't seem fixed.

Which of course means you're going to now provide more detailed STR, right? Because both Blake and me tried and failed to reproduce...
Flags: needinfo?(ntim007)
STR :
- Open customization mode
- *Quickly* click an item in the navbar.


Here's a screenshot of a panel opened during the customization mode transition by clicking the corresponding toolbar button.

I'll see if I can reproduce this on a clean profile.
Flags: needinfo?(ntim007)
(In reply to Tim Nguyen [:ntim] from comment #7)
> I'll see if I can reproduce this on a clean profile.
This is also reproducible on a clean profile, but you have to be really really really fast.
I'm able to hover the toolbar buttons at the beginning of the transition, but I have to reach the button really quickly. I can also bookmark about:customizing, but I have to be really really quick too.

I'll check if this is easily reproducible with jetpack add-ons.
comment #0 seemed to be about the items in the palette. Are you now talking only about items in the toolbar(s) ?
Flags: needinfo?(ntim007)
(In reply to :Gijs Kruitbosch from comment #9)
> comment #0 seemed to be about the items in the palette. Are you now talking
> only about items in the toolbar(s) ?

Yes, I'm talking about toolbar items, I probably wasn't clear enough about the bug summary.
Flags: needinfo?(ntim007)
Summary: Australis - During customization mode transition, items should be unclickable → During the customization mode transition you should not be able to click/hover items in the toolbars
I still can't reproduce this at all. I tried making the transition time longer from the browser toolbox, and even then, while the screen is transitioning, I can't click any of the items. It sounds like you're managing to hit the items between clicking "enter customize mode" and the transition starting. Almost all the code there (everything besides filling up the panel if it's not been opened, and waiting for delayedStartup to fire, which will realistically have happened already anyway) is sync, so I don't really see how you're able to do even that. Even more, I tried to do this by keyboard-navigating to the toplevel "Customize" menuitem, and hovering over a toolbarbutton with my mouse at the same time, and hitting enter and clicking right after each other, and even then I don't manage.

It's not clear to me why it's so different for you. Is your machine comparatively not very fast, or something? Are you on-purpose not opening the panel before entering customize mode? (you've not said how you're entering customize mode...)
Flags: needinfo?(ntim007)
(In reply to :Gijs Kruitbosch from comment #11)
> It's not clear to me why it's so different for you. Is your machine
> comparatively not very fast, or something? Are you on-purpose not opening
> the panel before entering customize mode? (you've not said how you're
> entering customize mode...)

My machine isn't particularly fast, but it's not too slow either. I'm on Windows 10. I reproduced the bug by entering the customization mode using the menu. But as I said, on a blank profile, you have to be quick to be able to click, or at least see the hover state. On a profile with a lot of addons, it's easier to reproduce. Also, I don't know if it's related, but I have e10s enabled.
Flags: needinfo?(ntim007)
Whiteboard: [qx] → [qx:spec]
In bug 1194846 you can accidentally hover a button, and it will provide a tooltip, even if you already performed 'mousedown' over the button. It's not necessary to be super-fast as tooltip can show during customization transition, but it won't disappear afterwards unless you click it.

I encountered that bug many times when I tried to immediately drag an item from navigation toolbar to bookmarks toolbar, but instead got a tooltip overlapping bookmarks toolbar, so I couldn't drop button on that area. I can provide a screencast, but the description seems pretty clear.

I added these bugs to "See also" list, because this bug is intended to fix them both.
See Also: → 1197212, 1194846
Mentor: gijskruitbosch+bugs
Keywords: steps-wanted

WFM with webextensions and everything and with everything that happened in between :)

Status: REOPENED → RESOLVED
Closed: 6 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.