Closed Bug 986877 Opened 6 years ago Closed 6 years ago

Intermittent shutdown assertion: ###!!! ABORT: file resource://gre/modules/AsyncShutdown.jsm, line 431

Categories

(Toolkit :: OS.File, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 965527

People

(Reporter: ehsan, Unassigned)

Details

https://tbpl.mozilla.org/php/getParsedLog.php?id=36562207&tree=Try&full=1
https://tbpl.mozilla.org/?tree=Try&rev=15e0bfb66789

b2g_ubuntu64_vm try opt test reftest on 2014-03-22 17:27:24 PDT for push 15e0bfb66789

17:30:41     INFO -  REFTEST TEST-START | Shutdown
17:30:41     INFO -  1395534641366	addons.xpi	WARN	Add-on reftest@mozilla.org is missing bootstrap method shutdown
17:30:41     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:30:41     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
17:31:42     INFO -  WARNING: A phase completion condition is taking too long to complete. Condition: OS.File: flush I/O queued before profile-before-change Phase: profile-before-change State: {"launched":true,"shutdown":false,"worker":true,"pendingReset":true,"latestSent":["Sat Mar 22 2014 17:30:51 GMT-0700 (PDT)","writeAtomic",[{"string":"/tmp/tmpXxCW9v/webapps/webapps.json"},{"ptr":"139815930269696"},{"tmpPath":{"string":"/tmp/tmpXxCW9v/webapps/webapps.json.tmp"},"bytes":32883}]],"latestReceived":null,"messagesSent":0,"messagesReceived":5,"messagesQueued":7,"DEBUG":false}
17:31:42     INFO -  *** UTM:SVC TimerManager:notify - notified @mozilla.org/b2g/webapps-update-timer;1
17:31:42     INFO -  ERROR: At least one completion condition failed to complete within a reasonable amount of time. Causing a crash to ensure that we do not leave the user with an unresponsive process draining resources. Conditions: [{"name":"OS.File: flush I/O queued before profile-before-change","state":"{\"launched\":true,\"shutdown\":false,\"worker\":true,\"pendingReset\":true,\"latestSent\":[\"Sat Mar 22 2014 17:30:51 GMT-0700 (PDT)\",\"writeAtomic\",[{\"string\":\"/tmp/tmpXxCW9v/webapps/webapps.json\"},{\"ptr\":\"139815930269696\"},{\"tmpPath\":{\"string\":\"/tmp/tmpXxCW9v/webapps/webapps.json.tmp\"},\"bytes\":32883}]],\"latestReceived\":null,\"messagesSent\":0,\"mozcrash INFO | Downloading symbols from: https://ftp-ssl.mozilla.org/pub/mozilla.org/b2g/try-builds/eakhgari@mozilla.com-15e0bfb66789/try-linux64_gecko/b2g-31.0a1.en-US.linux-x86_64.crashreporter-symbols.zip
17:31:53     INFO -  messagesReceived\":5,\"messagesQueued\":7,\"DEBUG\":false}"}] Phase: profile-before-change
17:31:53     INFO -  [Parent 2358] ###!!! ABORT: file resource://gre/modules/AsyncShutdown.jsm, line 431
17:31:53     INFO -  [Parent 2358] ###!!! ABORT: file resource://gre/modules/AsyncShutdown.jsm, line 431
17:31:53  WARNING -  PROCESS-CRASH | Shutdown | application crashed [@ mozalloc_abort(char const*)]
17:31:53     INFO -  Crash dump filename: /tmp/tmpXxCW9v/minidumps/4196fdc7-3eaf-cc09-74458ee7-747cf6fe.dmp
17:31:53     INFO -  Operating system: Linux
17:31:53     INFO -                    0.0.0 Linux 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64
17:31:53     INFO -  CPU: amd64
17:31:53     INFO -       family 6 model 45 stepping 7
17:31:53     INFO -       1 CPU
17:31:53     INFO -  Crash reason:  SIGSEGV
17:31:53     INFO -  Crash address: 0x0
17:31:53     INFO -  Thread 0 (crashed)
17:31:53     INFO -   0  libmozalloc.so!mozalloc_abort(char const*) [mozalloc_abort.cpp:15e0bfb66789 : 30 + 0x0]
17:31:53     INFO -      rbx = 0x00007f298aae8828   r12 = 0x00007f298aae8828
17:31:53     INFO -      r13 = 0x00007f296ed7ba30   r14 = 0x0000000000000000
17:31:53     INFO -      r15 = 0x0000000000000000   rip = 0x00007f2989d5e4e8
17:31:53     INFO -      rsp = 0x00007fff700447f0   rbp = 0x00007fff70044844
17:31:53     INFO -      Found by: given as instruction pointer in context
17:31:53     INFO -   1  libxul.so!NS_DebugBreak [nsDebugImpl.cpp:15e0bfb66789 : 421 + 0x9]
17:31:53     INFO -      rbx = 0x0000000000000003   r12 = 0x00007f298aae8828
17:31:53     INFO -      r13 = 0x00007f296ed7ba30   r14 = 0x0000000000000000
17:31:53     INFO -      r15 = 0x0000000000000000   rip = 0x00007f298726ce24
17:31:53     INFO -      rsp = 0x00007fff70044800   rbp = 0x00007fff70044844
17:31:53     INFO -      Found by: call frame info
17:31:53     INFO -   2  libxul.so!nsDebugImpl::Abort(char const*, int) [nsDebugImpl.cpp:15e0bfb66789 : 117 + 0xd]
17:31:53     INFO -      rbx = 0x0000000000000002   r12 = 0x00007f2988a5a05c
17:31:53     INFO -      r13 = 0x00007f29872a6258   r14 = 0x00007fff70044e40
17:31:53     INFO -      r15 = 0x0000000000000001   rip = 0x00007f298726ce8f
17:31:53     INFO -      rsp = 0x00007fff70044c70   rbp = 0x00007fff70044d20
17:31:53     INFO -      Found by: call frame info
17:31:53     INFO -   3  libxul.so!NS_InvokeByIndex [xptcinvoke_x86_64_unix.cpp:15e0bfb66789 : 164 + 0x40]
17:31:53     INFO -      rbx = 0x0000000000000002   r12 = 0x00007f2988a5a05c
17:31:53     INFO -      r13 = 0x00007f29872a6258   r14 = 0x00007fff70044e40
17:31:53     INFO -      r15 = 0x0000000000000001   rip = 0x00007f29872a6329
17:31:53     INFO -      rsp = 0x00007fff70044c80   rbp = 0x00007fff70044d20
17:31:53     INFO -      Found by: call frame info
17:31:53     INFO -   4  libxul.so!XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) [XPCWrappedNative.cpp:15e0bfb66789 : 2407 + 0x4]
17:31:53     INFO -      rbx = 0x0000000000000002   r12 = 0x0000000000000000
17:31:53     INFO -      r13 = 0x0000000000000002   r14 = 0x00007fff70044e40
17:31:53     INFO -      r15 = 0x0000000000000001   rip = 0x00007f2987ab6d30
17:31:53     INFO -      rsp = 0x00007fff70044d30   rbp = 0x0000000000000002
17:31:53     INFO -      Found by: call frame info
17:31:53     INFO -   5  libxul.so!XPC_WN_CallMethod(JSContext*, unsigned int, JS::Value*) [XPCWrappedNativeJSOps.cpp:15e0bfb66789 : 1280 + 0xb]
17:31:53     INFO -      rbx = 0x00007f2970c913d0   r12 = 0x00007f297d62a1f8
17:31:53     INFO -      r13 = 0x00007f29899b3160   r14 = 0x0000000000000002
17:31:53     INFO -      r15 = 0x00007f297d62a208   rip = 0x00007f2987aba33e
17:31:53     INFO -      rsp = 0x00007fff70044f40   rbp = 0x00007f298a632ae0
17:31:53     INFO -      Found by: call frame info
17:31:53     INFO -   6  libxul.so!js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) [jscntxtinlines.h:15e0bfb66789 : 239 + 0x12]
17:31:53     INFO -      rbx = 0x00007f298a632ae0   r12 = 0x00007f2987aba1d0
17:31:53     INFO -      r13 = 0x00007f298984d5c0   r14 = 0x00007fff70045ca0
17:31:53     INFO -      r15 = 0x00007f298a632ae0   rip = 0x00007f2988896b9b
17:31:53     INFO -      rsp = 0x00007fff70045070   rbp = 0x00007fff700450bc
17:31:53     INFO -      Found by: call frame info
17:31:53     INFO -   7  libxul.so!Interpret [Interpreter.cpp:15e0bfb66789 : 2614 + 0x18]
17:31:53     INFO -      rbx = 0x00007f297d62a200   r12 = 0x00007f297d62a218
17:31:53     INFO -      r13 = 0x00007f298984d5c0   r14 = 0x00007fff70045ca0
17:31:53     INFO -      r15 = 0x00007f298a632ae0   rip = 0x00007f2988890f27
17:31:53     INFO -      rsp = 0x00007fff70045520   rbp = 0x00007f297d62a210
17:31:53     INFO -      Found by: call frame info
17:31:53     INFO -   8  libxul.so!js::RunScript [Interpreter.cpp:15e0bfb66789 : 423 + 0xa]
17:31:53     INFO -      rbx = 0x00007f298a632ae0   r12 = 0x00007f297d7bd0c0
17:31:53     INFO -      r13 = 0x00007f297d7be340   r14 = 0x00007f298a632ae0
17:31:53     INFO -      r15 = 0x0000000000000001   rip = 0x00007f2988896817
17:31:53     INFO -      rsp = 0x00007fff70045bf0   rbp = 0x00007fff70045ca0
17:31:53     INFO -      Found by: call frame info
17:31:53     INFO -   9  libxul.so!js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) [Interpreter.cpp:15e0bfb66789 : 390 + 0x16]
17:31:53     INFO -      rbx = 0x00007f298a632ae0   r12 = 0x0000000000000001
17:31:53     INFO -      r13 = 0x00007fff70046250   r14 = 0x00007f298a632ae0
17:31:53     INFO -      r15 = 0x0000000000000001   rip = 0x00007f2988896ae4
17:31:53     INFO -      rsp = 0x00007fff70045c40   rbp = 0x00007fff70045c8c
17:31:53     INFO -      Found by: call frame info
17:31:53     INFO -  10  libxul.so!js::Invoke(JSContext*, JS::Value const&, JS::Value const&, unsigned int, JS::Value const*, JS::MutableHandle<JS::Value>) [Interpreter.cpp:15e0bfb66789 : 532 + 0x1b]
17:31:53     INFO -      rbx = 0x00007fff700464d0   r12 = 0x00007fff70046470
17:31:53     INFO -      r13 = 0x00007fff70046250   r14 = 0x00007f298a632ae0
17:31:53     INFO -      r15 = 0x0000000000000001   rip = 0x00007f2988897c23
17:31:53     INFO -      rsp = 0x00007fff700460f0   rbp = 0x00007fff70046240
17:31:53     INFO -      Found by: call frame info
17:31:53     INFO -  11  libxul.so!js::jit::DoCallFallback [BaselineIC.cpp:15e0bfb66789 : 8228 + 0x1d]
17:31:53     INFO -      rbx = 0x00007f298a632ae0   r12 = 0x00007fff700464c8
17:31:53     INFO -      r13 = 0x00007fff700464b8   r14 = 0x00007f296dede920
17:31:53     INFO -      r15 = 0x00007f2978fe0859   rip = 0x00007f2988a0609a
17:31:53     INFO -      rsp = 0x00007fff700461f0   rbp = 0x00007fff70046520
17:31:53     INFO -      Found by: call frame info
17:31:53     INFO -  12  0x7f298b92ad67
17:31:53     INFO -      rbx = 0xfffbff2970e5d340   r12 = 0x0000000000000000
17:31:53     INFO -      r13 = 0x00007fff70046db0   r14 = 0x00007f2970e5d340
17:31:53     INFO -      r15 = 0x00007f297d725840   rip = 0x00007f298b92ad68
17:31:53     INFO -      rsp = 0x00007fff70046460   rbp = 0x00007fff700464d0
17:31:53     INFO -      Found by: call frame info
Yeah, sorry!
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 965527
You need to log in before you can comment on or make changes to this bug.