Note: There are a few cases of duplicates in user autocompletion which are being worked on.

[Gamepad] The gamepad support is not enabled

RESOLVED INVALID

Status

()

Core
DOM: Events
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: jeromeenligne, Unassigned)

Tracking

({feature})

28 Branch
x86_64
Windows 7
feature
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20140314220517

Steps to reproduce:

Try to use your joypad with Firefox 28, which normally supports this function.





Actual results:

Nothing, joypad support is not enabled by default, you must go to about: config to enable this feature.
(Reporter)

Updated

3 years ago
Severity: normal → major
Keywords: feature
Priority: -- → P1

Comment 1

3 years ago
Please clear stated the preferences's name. 
dom.gamepad.enabled is enabled by default, on bug 878828.
Severity: major → normal
Component: Untriaged → DOM: Events
Flags: needinfo?(jerome.enligne)
Priority: P1 → --
Product: Firefox → Core
(Reporter)

Comment 2

3 years ago
I don't understand "Please clear stated the preferences's name. "

Thanks for resolved the bug.
Flags: needinfo?(jerome.enligne)

Comment 3

3 years ago
"you must go to about: config to enable this feature." is refer to which preference?
(Reporter)

Comment 4

3 years ago
It's in Address Bar, with url: "about:config"

--------------------
Dom: dom.gamepad.enabled
Value: True
----------------------

Comment 5

3 years ago
Yes, but this pref as true by default at current, not?
(Reporter)

Comment 6

3 years ago
Well just when I updated to Firefox 27 Firefox 28, this preference was not active, I have the activated myself. Is this the update that bug?

Comment 7

3 years ago
Sorry for oversight, this pref will be enabled by default on Fx29, not on Fx28.
see bug 878828 comment 29.
Yeah, sorry, the feature slipped from Firefox 28 to 29 due to a last-minute crash bug that was found.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.