Status

SeaMonkey
General
--
trivial
RESOLVED WONTFIX
17 years ago
12 years ago

People

(Reporter: Henrik Gemal, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I always really really hated the use of "www." in the start of URLs. It 
shouldn't be there.

So this bug is about removing fx www from www.google.com, www.netscape.com and 
www.mozilla.org.

I'll attach some patches.
> It shouldn't be there.

Really?  Why?
(Reporter)

Comment 2

17 years ago
It's not a bug. Just a personal hate....:)

Comment 3

17 years ago
www. *should* be there since without it the webserver may not accept the
connection. The webserver must be specifically configured to accept both
www.domain.com and domain.com as the same thing. At any time google or netscape
could turn off ability to accept non-www. prefixed requests. Recommend WONTFIX.
(Reporter)

Comment 4

17 years ago
hello!
I'm not recommending that all of the www. be removed. I'm just gonna remove the 
www. links from the source where the webserver is already accepting not www 
requests. Like http://google.com http://netscape.com http://mozilla.org etc...
These are NOT netwerk changes, just URL references in the code.

Comment 5

17 years ago
Still, www is universal. Why bother in removing that? All dot.com accepts www
(except on some subdomains), while not all dot.coms accept dot.com as an alias
to www.dot.com
I also recommend WONTFIX.
You said it yourself, not a bug, rather a personal hate. So, you can change the
code and use it yourself, but dont think for other people :)

Comment 6

17 years ago
Here's an interesting article on www:
http://e-observer.com/sections/marketing/end_of_www.html

Comment 7

17 years ago
This seems like a bad idea to me and recommend WONTFIX. Google.com, for example,
redirects (using HTTP header 302 moved temporarily) to www.google.com, so Google
must like the www. Removing it explicitly doesn't seem wise. 

Now if Mozilla was adding the www when it wasn't there, that'd be a different
thing. But it isn't. Try http://slashdot.org or http://netscape.com for example.

Of the three URLs you cite, the only 1 that Mozilla can reasonably depend on
always working is http://mozilla.org, and even that is somewhat debatable.
I'd like a fix for this, especially for mozilla.org. Note: www.mozilla.org is not
a real server, it's only a CNAME for gila.mozilla.org. mozilla.org has a real
DNS A entry (same IP as gila.mozilla.org though).

Similar for netscape.com: www.netscape.com is a CNAME for home-gslb.netscape.com
which has only one of the two IPs netscape.com has.

But I wouldn't recommend to use google.com because they don't seem to like it
(redirect and less IPs than www.google.com).

Comment 9

17 years ago
The WWW is there for a reason. www.domain.com is for their web server.
mail.domain.com is their mail server, news.domain.com is their news server.
gila.mozilla.org is different from komodo.mozilla.org and different still from
bugzilla.mozilla.org, etc. You're not just adding a superfluous www, you're
telling the domain controller what box you want to talk to.

I don't like Area codes, becauseno one that I currently call long distance has
an exchange the same as my local exchange, so why should I have to dial it?
Because without it, the phone system will default to the local exchange that is
in my area code.

Without WWW, the DNS server will default to whatever domain.com is set to, which
might not be www.

I know you want to remove this from just 3, but there is no good reason to do so
for the distro, just change your own. It will set a VERY bad precedent in form,
and one of the things Mozilla is trying to take the high road on is good and
proper form. Marking WONTFIX as has been suggested several times. Just modify
your own distro, not the tree.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.