Closed Bug 987049 Opened 11 years ago Closed 8 years ago

Gaia UI tests are often timing out when starting B2G on emulators in TBPL

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: davehunt, Unassigned)

References

Details

The Gaia UI tests are timing out on TBPL when restarting the b2g process. An example stacktrace is below:

12:42:01     INFO -  TEST-START test_cleanup_gaia.py
...
12:42:03     INFO -  test_cleanup_gaia (test_cleanup_gaia.TestCleanupGaia)
...
12:49:33     INFO -  ----------------------------------------------------------------------
12:49:33     INFO -  Traceback (most recent call last):
12:49:33     INFO -    File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette/marionette_test.py", line 145, in run
12:49:33     INFO -      self.setUp()
12:49:33     INFO -    File "/builds/slave/test/gaia/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 847, in setUp
12:49:33     INFO -      self.device.start_b2g()
12:49:33     INFO -    File "/builds/slave/test/gaia/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 716, in start_b2g
12:49:33     INFO -      .until(lambda m: m.find_element(*locator).is_displayed())
12:49:33     INFO -    File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette/wait.py", line 143, in until
12:49:33     INFO -      cause=last_exc)
12:49:33    ERROR -  TimeoutException: Traceback (most recent call last):
12:49:33     INFO -    File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette/wait.py", line 122, in until
12:49:33     INFO -      rv = condition(self.marionette)
12:49:33     INFO -    File "/builds/slave/test/gaia/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 716, in <lambda>
12:49:33     INFO -      .until(lambda m: m.find_element(*locator).is_displayed())
12:49:33     INFO -    File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette/marionette.py", line 1204, in find_element
12:49:33     INFO -      response = self._send_message('findElement', 'value', **kwargs)
12:49:33     INFO -    File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette/decorators.py", line 35, in _
12:49:33     INFO -      return func(*args, **kwargs)
12:49:33     INFO -    File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette/marionette.py", line 624, in _send_message
12:49:33     INFO -      self._handle_error(response)
12:49:33     INFO -    File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette/marionette.py", line 655, in _handle_error
12:49:33    ERROR -      raise NoSuchElementException(message=message, status=status, stacktrace=stacktrace)
12:49:33    ERROR -  TimeoutException: Timed out after 60.2 seconds, caused by <class 'marionette.errors.NoSuchElementException'>
12:49:33     INFO -  TEST-UNEXPECTED-FAIL | test_cleanup_gaia.py test_cleanup_gaia.TestCleanupGaia.test_cleanup_gaia |
12:49:33     INFO -  ----------------------------------------------------------------------
12:49:33     INFO -  Ran 1 test in 451.034s
12:49:33  WARNING -  FAILED (errors=1)

This points to this line in gaiatest, which is waiting for an app window to be displayed: https://github.com/mozilla-b2g/gaia/blob/7324a7b921b7b60de1427124e0efcafa91f4be75/tests/python/gaia-ui-tests/gaiatest/gaia_test.py#L716
Is this still something that needs to be done or can we close?
Flags: needinfo?(dave.hunt)
Assuming it's still valid then it should be left open, as it blocks bug 916368.
Flags: needinfo?(dave.hunt)
Component: Marionette → Gaia::UI Tests
Product: Testing → Firefox OS
Gaia and Firefox OS are no longer active projects.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.