SVG Text Path is not always bent

VERIFIED FIXED in Firefox 30

Status

()

defect
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: apragacz, Assigned: bas.schouten)

Tracking

({regression, testcase})

28 Branch
mozilla31
x86_64
All
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(firefox28 wontfix, firefox29+ wontfix, firefox30+ fixed, firefox31+ verified, firefox-esr24 unaffected, b2g-v1.3 wontfix, b2g-v1.4 fixed, b2g-v2.0 fixed)

Details

(Whiteboard: [testday-20140530])

Attachments

(3 attachments, 1 obsolete attachment)

Posted image bent-path-shifted.svg (obsolete) —
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20140317233501

Steps to reproduce:

Using FF 28.0 on Ubuntu Linux 64bit, I went to:

http://szopu.github.io/browser-demos/svg/text-gradient/bent-path-shifted.svg
http://szopu.github.io/browser-demos/svg/text-gradient/bent-path-shifted-text.svg

I attached the first SVG file to this bug report.


Actual results:

The SVG text was linear (e.g. It was horizontal, without any bending).


Expected results:

The SVG text should be bent, like it was in FF 26.0 (and probably also in FF 27.0), and in other browsers, like Chrome.
Component: Untriaged → SVG
Product: Firefox → Core
Status: UNCONFIRMED → NEW
Ever confirmed: true
Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/92f737230338
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131117170238
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/af0931327e49
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131117173035
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=92f737230338&tochange=af0931327e49

Regressed by:Bug 930577
Posted image reduced testcase
Attachment #8395606 - Attachment is obsolete: true
Bas, this is yet more breakage from using Moz2D Path. Can you take a look?
Flags: needinfo?(bas)
Attachment #8397822 - Attachment is patch: false
Attachment #8397822 - Attachment mime type: text/plain → image/svg+xml
I've found the bug, I'm working on a fix.
Assignee: nobody → bas
Status: NEW → ASSIGNED
Flags: needinfo?(bas)
This fixes a bug in inflection point finding. When solving the equation here I've incorrectly made the assumption that a constant rather a linear equation means the curve acceleration is constant, and therefor the curve is a straight line. This is wrong, when the second order derivative we're solving here is constant, the curve acceleration behaves linearly, and the curve will therefor still be a curve. The second order derivative being a constant is just indicative of their being no inflection points.
Attachment #8398056 - Flags: review?(jwatt)
Attachment #8398056 - Flags: review?(jwatt) → review+
Attachment #8398058 - Flags: review?(jwatt) → review+
Bas, I went ahead and landed the code patch.

https://hg.mozilla.org/integration/mozilla-inbound/rev/f853e8ff85ea

Do you want the test patch landed on m-i too, or will you land that in the Moz2D repo so that it gets picked up next time you sync us up?
Flags: needinfo?(bas)
https://hg.mozilla.org/mozilla-central/rev/f853e8ff85ea
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
Depends on: 992731
(In reply to Jonathan Watt [:jwatt] from comment #8)
> Bas, I went ahead and landed the code patch.
> 
> https://hg.mozilla.org/integration/mozilla-inbound/rev/f853e8ff85ea
> 
> Do you want the test patch landed on m-i too, or will you land that in the
> Moz2D repo so that it gets picked up next time you sync us up?

We don't currently have the tests in the Moz2D repo, so I'll take care of it.
Flags: needinfo?(bas)
Blocks: 997109
Bas, it is too late for 29 but could you consider an uplift to aurora? Thanks
Flags: needinfo?(bas)
Duplicate of this bug: 997109
(In reply to Sylvestre Ledru [:sylvestre] from comment #11)
> Bas, it is too late for 29 but could you consider an uplift to aurora? Thanks

I'm fine with that? I think it'll be very low risk, want me to request the uplift?
Flags: needinfo?(bas)
(In reply to Bas Schouten (:bas.schouten) from comment #13)
> (In reply to Sylvestre Ledru [:sylvestre] from comment #11)
> > Bas, it is too late for 29 but could you consider an uplift to aurora? Thanks
> 
> I'm fine with that? I think it'll be very low risk, want me to request the
> uplift?

Yes can you please proceed with that.
Comment on attachment 8398056 [details] [diff] [review]
Correctly deal with a constant acceleration.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 930577
User impact if declined: Incorrect behavior when following an svg path
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): Very low
String or IDL/UUID changes made by this patch: None
Attachment #8398056 - Flags: approval-mozilla-aurora?
Attachment #8398056 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #16)
> https://hg.mozilla.org/releases/mozilla-aurora/rev/cca7eb7fc75e
> 
> Looks like the test still needs to land?

The test isn't for mozilla-central, it's for the Moz2D test suite. If we want a reftest for this someone would need to craft it.
QA Whiteboard: [good first verify]
Verified fixed using Windows 7 64 bit (es-AR) and Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0. Verified in latest Nightly as well.
Status: RESOLVED → VERIFIED
Whiteboard: [testday-20140530]
You need to log in before you can comment on or make changes to this bug.