Closed Bug 987194 Opened 7 years ago Closed 7 years ago

Convert SVG masking to Moz2D

Categories

(Core :: SVG, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla33
Tracking Status
firefox30 --- unaffected
firefox31 --- unaffected
firefox32 + fixed
firefox33 --- fixed
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: jwatt, Assigned: jwatt)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(1 file)

We need to convert SVG masking to Moz2D.
Depends on: 988333
Blocks: 933019, 987190
No longer depends on: 987190
Blocks: 1024004
Attached patch patchSplinter Review
Attachment #8444159 - Flags: review?(matt.woodrow)
Requesting tracking v32 since certain web content is doing to mis-render (and fatal assert on debug builds) without this. See bug 1024004 for example.
Attachment #8444159 - Flags: review?(matt.woodrow) → review+
Blocks: 1028794
https://hg.mozilla.org/mozilla-central/rev/10b09f643dd6
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Comment on attachment 8444159 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 994081
User impact if declined: some broken SVG
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none

This fixes bug 1024004 and other similar bugs that were caused by bug 994081.
Attachment #8444159 - Flags: approval-mozilla-aurora?
Comment on attachment 8444159 [details] [diff] [review]
patch

Aurora approval granted.
Attachment #8444159 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.