Closed Bug 987312 Opened 6 years ago Closed 6 years ago

Remove /system/usr/icu/icudt46l.dat from builds

Categories

(Firefox OS Graveyard :: GonkIntegration, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3T fixed, b2g-v1.4 fixed)

RESOLVED FIXED
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed

People

(Reporter: fabrice, Assigned: ying.xu)

Details

(Whiteboard: [tarako_only][sprd310832])

Attachments

(1 file)

My tarako is running just fine without that file. This will free 7MB of ROM size, which is quite nice on some devices.

I'm not sure what the clean way is to remove that from the images.
blocking-b2g: --- → 1.3T?
Flags: needinfo?(yang.zhao)
Add Yang here.

Yang, please see these url and try to change icudt46l.dat to icudt32l.dat(24 language v1.3 support and 8 india language). And provide size of icudt32l.dat.
http://www.2cto.com/kf/201402/280580.html
http://www.csdn123.com/html/itweb/20130725/21535_21508_21534.htm

Fabrice, I don't think we can remove icudt46l.dat simply, because Arabic/Hindi/Myanmar language display/layout engine depend on this library. You should add mozilla multilocales/icu4c expert here to discuss whether we can remove icudt46l.dat.
Flags: needinfo?(fabrice)
I think our layout engine does not use the system libicu at all. We have an in-tree version at https://mxr.mozilla.org/mozilla-central/source/intl/icu/
Flags: needinfo?(fabrice)
It can be removed. That file is used by the icu4c library which gecko does not use for anything at all.
(In reply to Michael Wu [:mwu] from comment #3)
> It can be removed. That file is used by the icu4c library which gecko does
> not use for anything at all.

Can we remove icu4c library from git repo?
Flags: needinfo?(mwu)
(In reply to James Zhang from comment #4)
> (In reply to Michael Wu [:mwu] from comment #3)
> > It can be removed. That file is used by the icu4c library which gecko does
> > not use for anything at all.
> 
> Can we remove icu4c library from git repo?

Unfortunately that prevented my device from booting when I tried that.
(In reply to James Zhang from comment #4)
> (In reply to Michael Wu [:mwu] from comment #3)
> > It can be removed. That file is used by the icu4c library which gecko does
> > not use for anything at all.
> 
> Can we remove icu4c library from git repo?

It will cause build error because the build system depend on icu4c. But I think we can remove icudt46l.dat from Android.mk on my side.
Fabrice and Michael, I think we should check installed-files.txt again and find out which big library( > 100k ) is not used.

    24896772  /system/b2g/libxul.so
     7058080  /system/usr/icu/icudt46l.dat
     5331367  /system/b2g/omni.ja
     3817009  /system/b2g/webapps/wallpaper.gaiamobile.org/application.zip
     2717866  /system/b2g/webapps/settings.gaiamobile.org/application.zip
     2446650  /system/b2g/webapps/system.gaiamobile.org/application.zip
     2445811  /system/b2g/webapps/communications.gaiamobile.org/application.zip
     1976756  /system/xbin/busybox
     1972144  /system/b2g/webapps/ringtones.gaiamobile.org/application.zip
     1661292  /system/b2g/libnss3.so
     1260622  /system/b2g/webapps/keyboard.gaiamobile.org/application.zip
     1195296  /system/lib/libicui18n.so
     1194748  /system/lib/libstagefright.so
     1185412  /system/lib/libskia.so
     1164687  /system/b2g/webapps/clock.gaiamobile.org/application.zip
     1012692  /system/b2g/webapps/music.gaiamobile.org/application.zip
     1005988  /system/lib/libicuuc.so
      996664  /system/lib/libMali.so
      972754  /system/b2g/webapps/email.gaiamobile.org/application.zip
      826288  /system/lib/libcrypto.so
      753275  /system/b2g/webapps/validationtools.gaiamobile.org/application.zip
      715664  /system/lib/modules/itm_npi.ko
      695232  /system/lib/modules/itm_sta.ko
      671545  /system/b2g/webapps/pdfjs.gaiamobile.org/application.zip
      624290  /system/b2g/dictionaries/en-US.dic
      616032  /system/lib/modules/itm_ap.ko
      613232  /system/bin/tcp
      560740  /system/b2g/webapps/homescreen.gaiamobile.org/application.zip
      535456  /system/bin/wpa_supplicant
      492694  /system/etc/apns-conf.xml
      484401  /system/usr/share/zoneinfo/zoneinfo.dat
      445290  /system/b2g/webapps/calendar.gaiamobile.org/application.zip
      435948  /system/lib/libmedia.so
      430271  /system/b2g/webapps/sms.gaiamobile.org/application.zip
      418000  /system/b2g/libnssckbi.so
      400944  /system/b2g/webapps/costcontrol.gaiamobile.org/application.zip
      379312  /system/lib/libglib.so
      348707  /system/b2g/webapps/browser.gaiamobile.org/application.zip
      344674  /system/b2g/webapps/gallery.gaiamobile.org/application.zip
      341960  /system/lib/libmediaplayerservice.so
      330964  /system/lib/libsqlite.so
      322372  /system/lib/libsonivox.so
      319208  /system/bin/hostapd
      306096  /system/lib/libdbus.so
      284200  /system/b2g/libmozglue.so
      282248  /system/lib/libc.so
      275844  /system/lib/libwebrtc_audio_preprocessing.so
      258464  /system/lib/libaudioflinger.so
      258024  /system/bin/trw
      256949  /system/b2g/webapps/video.gaiamobile.org/application.zip
      256336  /system/lib/modules/mali.ko
      249784  /system/lib/libc_malloc_debug_qemu.so
      245696  /system/lib/libc_malloc_debug_leak.so
      236568  /system/bin/charge
      228884  /system/b2g/libfreebl3.so
      227945  /system/b2g/defaults/settings.json
      227408  /system/lib/libjpeg.so
      211180  /system/lib/libstlport.so
      210471  /system/b2g/webapps/camera.gaiamobile.org/application.zip
      203072  /system/lib/libstagefright_soft_aacdec.so
      194940  /system/lib/libbluetoothd.so
      190304  /system/fonts/DroidSerif-BoldItalic.ttf
      190184  /system/lib/libutils.so
      187364  /system/lib/libssl.so
      186112  /system/bin/gdbserver
      185228  /system/fonts/DroidSerif-Bold.ttf
      184920  /system/bin/iptables
      179236  /system/bin/ip6tables
      177560  /system/fonts/DroidSerif-Italic.ttf
      176184  /system/lib/libbinder.so
      172916  /system/fonts/DroidSerif-Regular.ttf
      172556  /system/lib/libgui.so
      169219  /system/b2g/webapps/engmode.gaiamobile.org/application.zip
      167780  /system/lib/libwilhelm.so
      162832  /system/lib/libstagefright_sprd_soft_h264dec.so
      160912  /system/lib/hw/camera.sc8810.so
      155828  /system/lib/libstagefright_sprd_aacdec.so
      154675  /system/b2g/webapps/marketplace.firefox.com/application.zip
      152028  /system/bin/mksh
      152016  /system/b2g/webapps/fm.gaiamobile.org/application.zip
      149916  /system/lib/libomx_avcdec_sw_sprd.so
      144624  /system/lib/libEGL.so
      142580  /system/lib/bluez-plugin/audio.so
      141528  /system/lib/libomx_avcdec_hw_sprd.so
      137828  /system/bin/ip
      136856  /system/lib/libGLESv2_dbg.so
      135852  /system/b2g/webapps/fl.gaiamobile.org/application.zip
      135344  /system/b2g/libsoftokn3.so
      134148  /system/bin/dbus-daemon
      129450  /system/b2g/webapps/wappush.gaiamobile.org/application.zip
      122238  /system/b2g/webapps/bluetooth.gaiamobile.org/application.zip
      121840  /system/xbin/strace
      116776  /system/fonts/FiraSansOT-BoldItalic.otf
      115828  /system/fonts/FiraSansOT-MediumItalic.otf
      115576  /system/xbin/hcidump
      113624  /system/lib/libstagefright_soft_vpxdec.so
      113436  /system/lib/libcamera_client.so
      113332  /system/fonts/FiraSansOT-Bold.otf
      113096  /system/lib/libstagefright_soft_h264dec.so
      113004  /system/lib/libpixelflinger.so
      112760  /system/fonts/FiraSansOT-Medium.otf
      112592  /system/fonts/FiraSansOT-RegularItalic.otf
      112476  /system/fonts/FiraSansOT-LightItalic.otf
      110144  /system/fonts/FiraSansOT-Regular.otf
      109484  /system/lib/libstagefright_omx.so
      109264  /system/fonts/FiraSansOT-Light.otf
      107420  /system/bin/toolbox
      104904  /system/b2g/b2g
      104864  /system/bin/dnsmasq
      103768  /system/lib/modules/trout_sdio.ko
      100968  /system/lib/libvorbisidec.so
      100760  /system/lib/libstagefright_sprd_soft_mpeg4dec.so
media server depend on sqlite, and sqlite depend on icu4c, and icu4c depend on icudt46l.dat. It will cause build error now.
Add Lianxiang here.
Flags: needinfo?(lianxiang.zhou)
(In reply to James Zhang from comment #8)
> media server depend on sqlite, and sqlite depend on icu4c, and icu4c depend
> on icudt46l.dat. It will cause build error now.

The build dependencies prevent you from removing icu4c completely. However, the data file can be removed. I know it can be done because it's been done before.
Flags: needinfo?(mwu)
Fixed on my side and Ying will update manifest.


commit e75e651bb07c60c92e508e9e35e887076000d63a
Author: james.zhang <james.zhang@spreadtrum.com>
Date:   Tue Mar 25 13:58:28 2014 +0800

    Bug #245770 mozilla Bug 987312 - Remove /system/usr/icu/icudt46l.dat from builds
    
    [bug number  ]
    [root cause  ]
    [changes     ]
    [side effects]
    [self test   ] build and test ok
    [reviewers   ]
    
    Change-Id: Iaf903b326fcec15b1cd4468becf4fada00ffc2ce
Flags: needinfo?(ying.xu)
change the branch of  external/icu4c
Attachment #8396174 - Flags: review?(mwu)
Attachment #8396174 - Flags: review?(fabrice)
Flags: needinfo?(ying.xu)
Flags: needinfo?(yang.zhao)
triage: 1.3T+ Tarako only to save ROM size
to Ying.xu as Ying's working on this. thanks
Assignee: nobody → ying.xu
blocking-b2g: 1.3T? → 1.3T+
Whiteboard: [tarako_only]
Attachment #8396174 - Flags: review?(mwu)
Attachment #8396174 - Flags: review?(fabrice)
Attachment #8396174 - Flags: review+
Ying, are you okay to uplift it? thanks!

--
Keven
Flags: needinfo?(ying.xu)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Flags: needinfo?(lianxiang.zhou)
Fixed on dolphin.

commit 2bb01561780583cc37bc667f0ea79f48a122d8a2
Author: james.zhang <james.zhang@spreadtrum.com>
Date:   Fri May 9 17:09:28 2014 +0800

    Bug #310832 mozilla Bug 987312 - Remove /system/usr/icu/icudt46l.dat from builds
    
    [bug number  ]
    [root cause  ]
    [changes     ]
    [side effects]
    [self test   ] test ok
    [reviewers   ]
    
    Change-Id: I863b75a6be782ae82058ab6208ddd35f319cc444
Whiteboard: [tarako_only] → [tarako_only][sprd310832]
You need to log in before you can comment on or make changes to this bug.