Scroll does not reposition on Undo or Redo automatically in Composer

VERIFIED DUPLICATE of bug 96850

Status

()

Core
Editor
--
major
VERIFIED DUPLICATE of bug 96850
17 years ago
10 years ago

People

(Reporter: TucsonTester1, Assigned: Kathleen Brade)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.3+)
Gecko/20010903 Netscape6/6.1b1
BuildID:    20010903

Upon performing an Undo or Redo operation, and the action takes place outside of
currently-viewed document area in Composer, repositioning does not occur to
bring back into view the edit being un- or redone.  In contrast, other edit
functions, like Cut and Delete, are able to pull/scroll the insertion point into
view.

Reproducible: Always
Steps to Reproduce:

        (1) Open a rather long, mostly-to-all text document 
                in Composer
        (2) Scroll all the way to the bottom and highlight a 
                paragraph near the bottom of the document
        (3) Either delete or Cut the highlight
        (4) Either navigate ``home'' (<Ctrl>+<Home>) or 
                scroll back to the top of the document
        (5) Perform an Undo function



Actual Results:  The document scroll does not ``jump'' to the site where the
actual Undo edit has just taken place; it remains positioned displaying the top
of the document.

Expected Results:  The screen should scroll immediately (or ``jump'') to the
point where the Undo or Redo action took place.

I suggest using a long, text-only document (_e.g.,_ a paper like the one located
at <http://ausweb.scu.edu.au/aw01/papers/refereed/morey_nase/paper.html>) for
this demonstration just to emphasise the observed results and issues involved. 
Scrolled position also does not matter, either, just so long the area being un-
or re-edited is positioned outside of Composer window view.  Insertion point
position also does not matter during the Undo/Redo step of this demonstration.

The effect of this behaviour as an inconvenience is enhanced when working in
long documents; but the posed problem is multiplied where someone wishes to
un-perform a series of edits.  In any instance, one would need to see all Undo
or Redo steps as they occur, in order to determine when to stop in the series.

This may be possibly a regression of the the old (fixed)  48297 .   


Note:
There is a workaround.  Once the Un- or Redo action has executed, press any one
of the four arrow-keys one time only, to bring the insertion point back into view.

Comment 1

17 years ago
Confirmed in 9-10 build
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
Is this a dupe of bug 96850 ?
(Assignee)

Comment 3

17 years ago


*** This bug has been marked as a duplicate of 96850 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Verified Dup
Status: RESOLVED → VERIFIED

Updated

10 years ago
Duplicate of this bug: 413304
You need to log in before you can comment on or make changes to this bug.