dragged bookmarks to top or bottom of bookmark folder

RESOLVED WONTFIX

Status

SeaMonkey
General
P5
enhancement
RESOLVED WONTFIX
17 years ago
14 years ago

People

(Reporter: Chris Dolan, Assigned: Matthew Paul Thomas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.3+) Gecko/20010904
BuildID:    20010904

When I drag a bookmark onto a bookmark folder, it appears at the bottom of the
folder (my bookmarks view is unsorted).  I prefer the NS 4.x behavior of the
bookmark appearing at the top of the folder.  A preference to change this
behavior, perhaps in the bookmarks window or in the main browser prefs, would be
nice.

Reproducible: Always

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 64768 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
Uh, no.  This is not a duplicate of bug 64768.  I indicated that I am using the
unsorted view.  I want to be able to drop a bookmark on a folder and have it
automatically appear at the top of that folder, like in NS 4.x.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Not sure I share this opinion... but keeping anyway just in case. Future. 
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Reporter)

Comment 4

17 years ago
Frankly it doesn't matter if you share my opinion.  This is the way *I* prefer
to sort my bookmarks (recent bookmarks are usually more important to me). 
That's why I suggested a prefs option, rather than simply a change in behavior.

OK with future (post 1.0 is fine).
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW

Comment 6

17 years ago
Mass move Ben's bugs dumped on me marked future with p5 to get off my untriaged
radar. You can filter out this email by looking for "ironstomachaussie"
Priority: -- → P5

Comment 7

17 years ago
-> UI Design
Assignee: pchen → mpt
Component: Bookmarks → User Interface Design
QA Contact: claudius → zach

Comment 8

17 years ago
*** Bug 124312 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

16 years ago
Wontfix, because such a pref would be considerably more cluttersome than useful.

If you think the current behavior is wrong, feel free to file a bug saying that
it should be changed. Don't file a bug asking for a pref.
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 10

16 years ago
WTF?

I clearly have acknowledged that my bookmark sorting preference is in the
minority.  This is a matter of *opinion*, which is why I requested a preference
rather than a behavior change.  I flagged this as an enhancement, rather than as
a normal bug, because the current behavior is not wrong, it's just not what I
prefer.  Hence the request for a preference.  It doesn't have to be a GUI
preference.  I'm completely content with a user.js solution.

If it's a WONTFIX because it's too much of a pain to implement, that's fine. 
I'll accept that.  But telling me not to file a enhancement request?  That's
ludicrous.  And telling me that a feature I've requested won't be useful? 
That's just dumb.  It would be useful to *me*.  I've already explained why I
think it would be useful.  Decreeing that my opinion is invalid is quite insulting.

I'm not saying that this shouldn't be a WONTFIX, but I am saying that your
stated reasons for marking it as such are very confrontational.

Updated

16 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.