mail news crashes on startup if you already have an account setup [@ SECITEM_CompareItem()]



MailNews: Message Display
17 years ago
11 years ago


(Reporter: Jason Wong, Unassigned)



Firefox Tracking Flags

(Not tracked)


(crash signature)



17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.3+)
BuildID:    2001090703

mail news crashes with today's build (2001090703) if you already have a mail
accout setup.  it works fine if setting up an account for the first time.  

I've already done a clean install, and it still crashes.  I do have ssl enabled.

Reproducible: Always
Steps to Reproduce: mail news

Actual Results:  crash

Expected Results:  shouldn't crash

Comment 1

17 years ago
sorry upping the severity as this is pretty critical
Severity: normal → critical

Comment 2

17 years ago
seeing this on linux 2001090906.

marking os = all
OS: Windows 2000 → All

Comment 3

17 years ago
still seeing this on 2001091008

Comment 4

17 years ago
ok, did some more snooping around.  it's definitely the ssl that's causing this
crash.  I'm not sure if this is affecting pop, as I'm only using imap.  but
after creating a new account, i can use mail without crashing only when ssl is
disabled.  enabling it causes a crash on next mail startup.  

something about this horks everything.  setting .isSecure in prefs.js back to
false allows me to bring up mail, but it just sits there and does nothing. 
clicking on get msg results in mail just sitting trying to connect, but never

to get things back on  track, i have to remove the account from mail and news
preferences and then re-add it.

I've sent talkback ID TB35229767Q on this crash

Comment 5

17 years ago
Incident ID 35229767
Stack Signature SECITEM_CompareItem() 30171045
Bug ID
Trigger Time 2001-09-10 22:43:17
Email Address
User Comments
Build ID 2001091009
Product ID MozillaTrunk
Platform ID Win32
Trigger Reason Access violation
Stack Trace
[d:\builds\seamonkey\mozilla\security\manager\ssl\src\nsNSSCallbacks.cpp, line 274]
[d:\builds\seamonkey\mozilla\security\manager\ssl\src\nsNSSIOLayer.cpp, line 718]
MSVCRT.DLL + 0x115a6 (0x780115a6)
Ever confirmed: true
Keywords: crash

Comment 6

16 years ago
I am experiencing this on the Mac OS X build 0.9.9.  As soon as I click on the
Mail icon, it crashes.  Here is the crash report:

Date/Time:  2002-03-26 15:39:37 +0000
OS Version: 10.1.3 (Build 5Q45)

Command:    Mozilla
PID:        466

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_INVALID_ADDRESS (0x0001) at 0xf5fcf5fd

Thread 0:
 #0   0x005056b0 in PR_Lock
 #1   0x005056a4 in PR_Lock
 #2   0x00575c78 in nsHashtable::Get(nsHashKey *)
 #3   0x00578384 in nsSupportsHashtable::Get(nsHashKey *)
 #4   0x02950d1c in GetCacheElement__16nsMsgFolderCacheFPCciPP24nsIMsgFolderCacheE
 #5   0x02d2586c in nsMsgDBFolder::GetFolderCacheElemFromFileSpec(nsIFileSpec *)
 #6   0x02d25a78 in nsMsgDBFolder::ReadDBFolderInfo(int)
 #7   0x02d278e8 in nsMsgDBFolder::GetFlags(unsigned int *)
 #8   0x02ca8388 in AddSubfolderWithPath__16nsImapMailFolderFP12nsAutoStringP11nsI
 #9   0x02ca8df0 in nsImapMailFolder::CreateSubFolders(nsFileSpec &)
 #10  0x02ca92dc in nsImapMailFolder::GetSubFolders(nsIEnumerator **)
 #11  0x02929d04 in nsMsgFolderDataSource::createFolderOpenNode(nsIMsgFolder *,  *)
 #12  0x02928114 in createFolderNode__21nsMsg
 #13  0x029257d4 in GetTarget__21nsMsgFolderDataSourceFP14nsIRDFResourceP14nsIRDFR
 #14  0x0292d7b8 in GetTargetHasAssertion__FP16nsIRDFDataSourceP14nsIRDFResourceP1
 #15  0x0292d050 in nsMsgFolderDataSource::DoFolderHasAssertion(nsIMsgFolder *,  *)
 #16  0x02925fbc in HasAssertion__21nsMsgFolderDataSourceFP14nsIRDFResourceP14nsIR
 #17  0x020702fc in nsXULOutlinerBuilder::IsContainerOpen(nsIRDFResource *, int *)
 #18  0x0206fb78 in OpenSubtreeOf__20nsXULOutlinerBuilderFPQ214nsOutlinerRows7Subt
 #19  0x0206f910 in nsXULOutlinerBuilder::OpenContainer(int, nsIRDFResource *)
 #20  0x0206dd88 in nsXULOutlinerBuilder::Rebuild(void)
 #21  0x0203a9a4 in AttributeChanged__20nsXULTemplateBuilderFP11nsIDocumentP10nsIC
 #22  0x0200b324 in nsXULDocument::AttributeChanged(nsIContent *, int, nsIAtom
*, int, int)
 #23  0x0204b79c in nsXULElement::SetAttr(nsINodeInfo *, nsAString const &, int)
 #24  0x020466f0 in nsXULElement::SetAttribute(nsAString const &, nsAString const &)
 #25  0x005ba7ec in XPTC_InvokeByIndex
 #26  0x005ba6e0 in XPTC_InvokeByIndex
 #27  0x037459c4 in 0x37459c4
 #28  0x0374be9c in XPC_WN_CallMethod(JSContext *, JSObject *, unsigned int,
long *, long *)
 #29  0x01bf856c in js_Invoke
 #30  0x01c0063c in 0x1c0063c
 #31  0x01bf85c4 in js_Invoke
 #32  0x01bf8810 in js_InternalInvoke
 #33  0x01bd9bac in JS_CallFunctionValue
 #34  0x022812b0 in nsJSContext::CallEventHandler(void *, void *, unsigned int,
void *, int *, int)
 #35  0x0229fb44 in nsJSEventListener::HandleEvent(nsIDOMEvent *)
 #36  0x01e24ee0 in HandleEventSubType__22nsEventListenerManagerFP16nsListenerStru
 #37  0x01e26a24 in 0x1e26a24
 #38  0x022863c4 in GlobalWindowImpl::HandleDOMEvent(nsIPresContext *, nsEvent
*,  *)
 #39  0x01f5cac8 in DocumentViewerImpl::LoadComplete(unsigned int)
 #40  0x02236058 in nsDocShell::EndPageLoad(nsIWebProgress *, nsIChannel *,
unsigned int)
 #41  0x0224d624 in 0x224d624
 #42  0x022357b0 in nsDocShell::OnStateChange(nsIWebProgress *, nsIRequest *,
int, unsigned int)
 #43  0x0357e850 in FireOnStateChange__15nsDocLoaderImplFP14nsIWebProgressP10nsIRe
 #44  0x0357d710 in nsDocLoaderImpl::doStopDocumentLoad(nsIRequest *, unsigned int)
 #45  0x0357d4ac in nsDocLoaderImpl::DocLoaderIsEmpty(void)
 #46  0x0357d1b4 in nsDocLoaderImpl::OnStopRequest(nsIRequest *, nsISupports *,
unsigned int)
 #47  0x02ef5b54 in nsLoadGroup::RemoveRequest(nsIRequest *, nsISupports *,
unsigned int)
 #48  0x028b6354 in imgRequestProxy::OnStopRequest(nsIRequest *, nsISupports *,
unsigned int)
 #49  0x028b42f8 in imgRequest::OnStopRequest(nsIRequest *, nsISupports *,
unsigned int)
 #50  0x028b0a84 in ProxyListener::OnStopRequest(nsIRequest *, nsISupports *,
unsigned int)
 #51  0x02f31024 in nsJARChannel::OnStopRequest(nsIRequest *, nsISupports *,
unsigned int)
 #52  0x02f4a6d0 in nsOnStopRequestEvent::HandleEvent(void)
 #53  0x02f49ae0 in nsARequestObserverEvent::HandlePLEvent(PLEvent *)
 #54  0x005f0db0 in PL_HandleEvent
 #55  0x005f0c1c in PL_ProcessPendingEvents
 #56  0x00596abc in nsEventQueueImpl::ProcessPendingEvents(void)
 #57  0x00596b64 in nsEventQueueImpl::ProcessPendingEvents(void)
 #58  0x00596b64 in nsEventQueueImpl::ProcessPendingEvents(void)
 #59  0x0361088c in nsMacNSPREventQueueHandler::ProcessPLEventQueue(void)
 #60  0x03610650 in nsMacNSPREventQueueHandler::RepeatAction(EventRecord const &)
 #61  0x02345b14 in Repeater::DoRepeaters(EventRecord const &)
 #62  0x036248f8 in nsMacMessagePump::DispatchEvent(int, EventRecord *)
 #63  0x036244d0 in nsMacMessagePump::DoMessagePump(void)
 #64  0x03623e4c in nsAppShell::Run(void)
 #65  0x01c6b28c in nsAppShellService::Run(void)
 #66  0x004c8bb4 in main1(int, char **, nsISupports *)
 #67  0x004c968c in main

Thread 1:
 #0   0x7000497c in syscall
 #1   0x70557600 in BSD_waitevent
 #2   0x70554b80 in CarbonSelectThreadFunc
 #3   0x7002054c in _pthread_body

Thread 2:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005b34 in mach_msg_overwrite
 #2   0x70030abc in _lookup_one
 #3   0x70035e5c in lu_gethostbyname
 #4   0x70036318 in gethostbyname
 #5   0x705592f0 in BSD_gethostbyname_r
 #6   0x70558098 in AsyncInetStringToAddress
 #7   0x705594d4 in CarbonOperationThreadFunc
 #8   0x7002054c in _pthread_body

Thread 3:
 #0   0x70044cf8 in semaphore_timedwait_signal_trap
 #1   0x70044cd8 in semaphore_timedwait_signal
 #2   0x7003f2b8 in _pthread_cond_wait
 #3   0x70283ea4 in TSWaitOnConditionTimedRelative
 #4   0x7027d748 in TSWaitOnSemaphoreCommon
 #5   0x702c2078 in TimerThread
 #6   0x7002054c in _pthread_body

Thread 4:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x70250ab0 in TSWaitOnCondition
 #3   0x7027d730 in TSWaitOnSemaphoreCommon
 #4   0x70243d14 in AsyncFileThread
 #5   0x7002054c in _pthread_body

Thread 5:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x7055b884 in CarbonInetOperThreadFunc
 #3   0x7002054c in _pthread_body

Thread 6:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005a04 in mach_msg
 #2   0x7017bf98 in __CFRunLoopRun
 #3   0x701b7100 in CFRunLoopRunSpecific
 #4   0x7017b8e0 in CFRunLoopRunInMode
 #5   0x7061be08 in
XIOAudioDeviceManager::NotificationThread(XIOAudioDeviceManager *)
 #6   0x706141c0 in CAPThread::Entry(CAPThread *)
 #7   0x7002054c in _pthread_body

Thread 7:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005a04 in mach_msg
 #2   0x70026a2c in _pthread_become_available
 #3   0x70026724 in pthread_exit
 #4   0x70020550 in _pthread_body

PPC Thread State:
  srr0: 0x005056b0 srr1: 0x0200d030                vrsave: 0x00000000
   xer: 0x00000008   lr: 0x005056a4  ctr: 0x70000a30   mq: 0x00000000
    r0: 0x005056a4   r1: 0xbfffc150   r2: 0x00114000   r3: 0x00000000
    r4: 0x00000000   r5: 0x001171b0   r6: 0x00000001   r7: 0x00109494
    r8: 0x00054524   r9: 0x80240e10  r10: 0x00000024  r11: 0x80241774
   r12: 0x70000a30  r13: 0x00000000  r14: 0x00000033  r15: 0x0005eae0
   r16: 0x00000001  r17: 0x80160fa8  r18: 0x0005ac08  r19: 0x00001707
   r20: 0x00000000  r21: 0x0000001c  r22: 0x70004234  r23: 0x700042c8
   r24: 0x7016b0dc  r25: 0x006bac3c  r26: 0x8081ab5c  r27: 0x00000000
   r28: 0x00000000  r29: 0xbfffef00  r30: 0x87859393  r31: 0x00000001


Comment 7

16 years ago
Confirm: Occurs on Windows 2000 Build 2195 (SP2) with Mozilla 1.1a; HOWEVER, it
does not crash Mozilla -- it simply doesn't load.

Comment 8

16 years ago
Seeing this with recent builds, too. mozilla-win32-2002081209 has been working
well, but mozilla-win32-2002100508 and some older builds i tried start up the
mailer and want to setup a new email account. if i cancel (or generate a new
account, it does not matter), it crashes for no appearant reason. some of the
talkbacks from those incidents include:


Comment 9

15 years ago
This bug has been resolved.

Comment 10

15 years ago
Something like this bug seems to have resurfaced in Moz 1.5b. Most of the time
when I start Mail/News (either direct or with starting Navigator first) it
crashes. I use Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.5b)
Product: Browser → Seamonkey

Comment 11

14 years ago
I was having this problem too.  Still occuring with today's build (12/3/04)
Noticed in the moment before it crashed to desktop (while TalkBack agent was
running) that it had been in the process of checking newgroups.

I had noticed that it was asking for a password to check newsgroups on launching
since I installed build a few days ago -- new behavior.  

I tried changing to "work off line" and was able to launch Mail, no problem.

I unsubscribed to the newsgroups -- which I never check anymore
because they now use a web based newsgroup -- and am now able to launch mail
while on line.  I suspect the problem had to do with the no
longer existing (therefore my password wasn't working); maybe they eliminated in stages so that first it only asked for a password, and now
whatever has happened crashes mail to desktop.

It's still a bug -- it shouldn't crash to desktop if you are subscribed to a
group that ceases to exist, especially since it's a real trick to unsubscribe if
Mozilla crashes every time you open your Mail window. 


13 years ago
Assignee: sspitzer → mail

Comment 12

12 years ago
Do you still see this problem?
I've not seen this in last couple years.

Comment 13

11 years ago
I have newsgroups turned off, so it hasn't come up

Comment 14

11 years ago
wfm Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007081503 SeaMonkey/2.0a1pre
and not in talkback list of crashers
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Summary: mail news crashes on startup if you already have an account setup → mail news crashes on startup if you already have an account setup [@ SECITEM_CompareItem()]
Crash Signature: [@ SECITEM_CompareItem()]
You need to log in before you can comment on or make changes to this bug.