Can't remove a line that is listed

VERIFIED INVALID

Status

()

VERIFIED INVALID
18 years ago
18 years ago

People

(Reporter: sjarrettsprague, Assigned: mozeditor)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Have tried to use composer to create lists eg.

1. line 1
2. line 2
3. line 3

I am having difficulty trying to remove a line I currently have an email saved
which has the structure


1. text
2. text
3. text

1.

I cant remove the second 1. If I click on the add/remove numbered list I get

1.
    1.

There seems to be no way of removing it.
reassign to editor backend
Assignee: ducarroz → brade
Component: Composition → Editor
Product: MailNews → Browser
QA Contact: sheelar → sujay
(Reporter)

Comment 2

18 years ago
Having found the format menu and looking in list the line with a 1. in it has a
. against none, indicating it is not a list item, though it clearly has a one
against it. 

Comment 3

18 years ago
-->jfrancis
Assignee: brade → jfrancis
(Assignee)

Comment 4

18 years ago
please attach the html source for your testcase.  Otherwise this is a WORKSFORME.

Comment 5

18 years ago
This is what I see in the e-mail message from S A Jarrett-Sprague:

<html>
<head>
</head>
<body>
<font face="Helvetica, foo, sans-serif">Hi<br>
<br>
<br>
<big><font face="Times New Roman, Times, serif">This is the email with the
strange list I can't delete. What I expect should happen is I should be on
line 1. or 2. and clicking on the apply or remove bullet item should delete
the item.<br>
<br>
<font face="Helvetica, foo, sans-serif">Th</font><font face="Helvetica, foo, 
sans-serif">
is is arial</font></font></big><big><br>
<br>
</big></font><big><font face="Times New Roman, Times, serif"><font face="Times 
New Roman, Times, serif">
This is times</font><br>
<br>
</font></big><font face="Courier New, Courier, monospace"><big>This is courier</
big></font><br>
<br>
<br>
   This is a list<br>
<ol>
  <li>no 1</li>
  <li>no 2</li>
  <li><br>
  </li>
</ol>
   This is another list<br>
<ol>
  <li>e</li>
  <li>3</li>
  <li><br>
  </li>
</ol>
<ol>
  <li><br>
  </li>
  <li><br>
    <br>
    <br>
    <br>
    <br>
    <br>
  </li>
</ol>
</body>
</html>


Bug Reporter--could you please describe how you got to this point?  Are you able 
to recreate in Composer with an empty page?
(Assignee)

Comment 6

18 years ago
It works as designed.  He is only having trouble with the last list item, I bet.  
That's because it looks empty, but is not. It contains a bunch of breaks.

There may be a real bug here somewhere - for instance, there may be a bug that is 
leaving too many br's behind when deleting things in list items that caused him 
to get into this state.  But given this state, the list behavior is working as 
intended.  This is so you can make another list inside a list tiem if you have 
other block seperators (like a <p>, or a <br>, etc) in it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 7

18 years ago
Verified
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

18 years ago
I can get the same problem in composer, am sending html example.
(Reporter)

Comment 9

18 years ago
Created attachment 49494 [details]
deleting list items
You need to log in before you can comment on or make changes to this bug.