-remote 'openURL("xyz")' while no browser window up causes an unchromed browser window to display

CLOSED FIXED

Status

()

CLOSED FIXED
17 years ago
17 years ago

People

(Reporter: leary, Assigned: blizzard)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [xremote])

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3+) Gecko/20010907
BuildID:    2001090708

launching:

 /path/to/mozilla/mozilla -remote "openURL($url,new-window)"

via a script (where $url is one) only resets the open browser to a fresh, blank
browser, wiping out the page you were looking at, disabling the back button, and
not launching the URL.

Reproducible: Always
Steps to Reproduce:
I'm using url_handler.sh, but this should repro just by using commandline
similar to above.

Actual Results:  see description

Expected Results:  old window is OK
new window has URL
->blizzard

Reporter: X-remote is being completely re-written. look at bug 98603 for
details.  I haven't seen it broken as badly as you describe.  The worst I've
seen it get is the way i described in bug 94289.  Is that what you are talking
about?
Assignee: asa → blizzard
Severity: critical → normal
Component: Browser-General → XP Miscellany
(Reporter)

Comment 2

17 years ago
bug 94289 is probably related, but is not what I'm seeing.  What I see looks
like a fresh, normal browser instance with a blank document area.  It's a
working browser, but if I'd had any data in a form, it would be gone.  That's
data loss == critical.
Depends on: 98603
QA Contact: doronr → sairuh
Summary: mozilla -remote "openURL($url,new-window)" badly broken → -remote 'openURL("xyz")' while no browser window up causes an unchromed browser window to display
(Assignee)

Updated

17 years ago
Whiteboard: [xremote]
(Assignee)

Comment 3

17 years ago
Fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

17 years ago
verified in 2001090721

closing
Status: RESOLVED → CLOSED

Comment 5

17 years ago
BTW, this was probably a duplicate of bug 90580

Updated

17 years ago
Component: XP Miscellany → X-remote
You need to log in before you can comment on or make changes to this bug.