Main window not honoring background colors

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: mkaply, Unassigned)

Tracking

({regression})

Trunk
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

5 years ago
In Australis, the main window no longer accepts a background color. It is always transparent.

I'm providing a testcase to show this, but this has a major impact on our theming project.

To see this, load any persona/background.

Enable chrome devtools.

Bring up the scratchpad and set the environment to browser.

Type:

document.getElementById("main-window").style.backgroundImage = "none";

The color of the main window should revert to the background color of the persona, not transparent.
Reporter

Updated

5 years ago
Keywords: regression
Wait, does that mean that background-image works on the window even when -moz-appearance is not none?

I think it shouldn't, and we should whatever bug that causes the window buttons to turn black if -moz-appearance is none.
Reporter

Comment 3

5 years ago
> Wait, does that mean that background-image works on the window even when -moz-appearance is not none?

Yes, that's how it has always worked on Windows. -moz-appearance is set to -moz-win-borderless-glass and personas/backgrounds apply just fine by setting background-color and background-image directly on the main-window.

This was before the patch from bug 889085

> I think it shouldn't, and we should whatever bug that causes the window buttons to turn black if -moz-appearance is none.

I have no opinion on that, I just know this is a pretty serious regression for our add-on and I'd like to get something done before Firefox 29 ships.
Reporter

Comment 4

5 years ago
I believe this display: none:

http://mxr.mozilla.org/mozilla-central/source/browser/themes/windows/browser-aero.css#102

is what is making them disappear.

If I remove the display: none via DOM inspector, the buttons function, but they still don't draw properly.

Comment 5

5 years ago
This is also a bit odd: In the windows version of global.css there's a '-moz-appearance: window;" rule, but it looks like NS_THEME_WINDOW isn't used in nsNativeThemeWin.cpp.
Reporter

Comment 6

5 years ago
I'd love to figure out how to fix this correctly right now, but I don't think we have time.

I know this breaks background/Personas for Firefox 29 and my wager is it is breaking themes as well.

My guess is it's the second patch from bug 889085 that is causing this. Should it be backed out or just made Mac only.

I'll put together whatever patch is needed.
Blocks: 889085
Backing it out from 29 seems safest. For 30+ we can put together a proper patch.

Comment 8

5 years ago
Backing out both patches makes most sense, since the first one depends on the second.

Comment 9

3 years ago
It seems from bug 889085 that it was indeed backed out; can this be resolved WFM?
Flags: needinfo?(mozilla)
Reporter

Updated

3 years ago
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(mozilla)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.