Save the content-base into the saved HTML file

VERIFIED FIXED in mozilla1.1alpha

Status

SeaMonkey
Composer
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: marina, Assigned: Brade)

Tracking

Trunk
mozilla1.1alpha

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
 
(Reporter)

Comment 1

17 years ago
I didn't mean to post this bug without any info, just hit Enter accidentally :-)
This bug was split from 90242. We have to add to Editor the capability to save
the content-base into the saved HTML file to avoid breaking links. 
When we are saving a web page with links as an html file to the local drive we
do not pass the link info to the saved page. When such a file is attached to
your message the links could not be displayed because we don't know anymore
where this page comes from and we cannot specify a Content-Base and
Content-Location information into the message.




Summary: Save the content-base into the saved HTML file → Save the content-base into the saved HTML file
over to editor... and I'm almost certain this is a dup.
Component: Compositor → Editor
Whiteboard: DUPEME
Reassigning to editor-core
Assignee: kmcclusk → kin
QA Contact: petersen → sujay

Comment 4

17 years ago
--> Composer
Assignee: kin → syd
Component: Editor: Core → Editor: Composer

Comment 5

17 years ago
Charlie -- EDITORBASE?
Assignee: syd → cmanske

Comment 6

17 years ago
I'm not sure what you are requesting. The root cause of the problem is the
absolute links to "file" URLs that often results from using Composer.
We are fixing these issues in the context of Publishing work. Currently, links
and images added from the dialogs automatically use relative URLs and allow user
control over this.
So are you suggesting always writing the location URL as the BASE tag whenever
Composer saves a file?
it's not only for page composed by editor but for any viewed page in the browser
that you save. We need to be sure that the user will be able to reopen it
without loosing information beacause we lost the content-base.

Comment 8

17 years ago
Ducarroz is correct: This is a general problem when saving files from any module,
and it must be fixed separately in each: Browser, Composer, and Mail.
However, I notice that Mail has marked bug 90242 as "wontfix".
This problem would be solved for many (but not all) remote URL pages saved to 
disk by using the the remote URL as the HREF value in a BASE tag in the file. 
The same could be done in Browser and Mail save file code.
Boris: I don't see an dups for Composer; do you think this is a known issue for
saving from Browser? Or were you thinking of bug 90242?
Status: NEW → ASSIGNED
Whiteboard: DUPEME → EDITORBASE
Target Milestone: --- → mozilla0.9.7

Comment 9

17 years ago
Brade: Since you are working on the save code, its seems better to hand this off
to you. Do you think it would be good to write a "BASE" tag whenever we save a
file? Are there plans to move save code out of individual modules so this stuff
doesn't have to be repeated?
Assignee: cmanske → brade
Status: ASSIGNED → NEW
(Assignee)

Updated

17 years ago
OS: Windows 2000 → All
Hardware: PC → All
(Assignee)

Comment 10

17 years ago
Charley said I could remove EDITORBASE from this bug since 85% of our users
won't run into a problem like this.
Whiteboard: EDITORBASE
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.7 → mozilla1.1
*** Bug 93354 has been marked as a duplicate of this bug. ***
As content-base is now obsolete, we should save content-location. See bug 82745
*** Bug 99416 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
Mozilla/5.0 (Windows; U; Win98; de-AT; rv:0.9.8+) Gecko/20020302 (08)

Using the editor/composer for working on existing html-files, I had to learn,
that the composer inserts a base-tag when I save the file after the changes. As
"base" is inserted the actual location _on_the_harddisk_ ! I do *not* think,
that that is a very god Idea:
Me and all other users of the composer I know have a complete image of their
webspace on the harddisk, where they work on their html-pages. Because I only
use relative links to ohter elements, there is no problem to test the pages
offline on the harddisk, and there is no problem after publishing on the server. 
But it will cause very big problems with the pages on the server, if there is a
base-tag with a pointer to a locatkion on my private-PC-harddisk: no pictures
are shown, no link to elements of my webspace will work, beacuse, fo course, no
access to my private harddisk is possible.
For someone, who does not know of the feature "automatic insert base tag", that
will cuase big Problems. 

These Problems can not be seen with mozilla or NS62, because theses Browsers
seem to ignore base-tags with pointer to private PC-harddisks. With these
Browsers html-pages with base-tag worked  without problems on the server.
But when I used other Browsers as opera, IE6, NC4.7, the pages were not shown
correctly (no images with relative links pointed shown, and relative links
pointed to my private-PC-harddisk).

I think, this feature should urgently be taken away! The problem with
inline-atts. etc. is not so important, I think, it is more sensful to send a
link to the page by email, and than the page should be viewed online with the
browser.

Aditionally, if you save th page in the composer with a new name, the base-tag
contents the _old_ filename - that was intended? 
(Assignee)

Comment 15

17 years ago
The original problem described here is not really a problem any more; if it is,
please explain and reopen bug.

The problem described by Rainer Bielefeld is a separate issue and has been
resolved in the latest builds.  Composer no longer adds or modifies existing
base tags.  We have decided that the user will have to manually adjust base tags
if that is desired.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 16

16 years ago
verified...REOPEN if you are still experiencing this problem..
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.