Closed Bug 987938 Opened 6 years ago Closed 6 years ago

[B2G][Browser] White Screen encountered when selecting "Try Again" on a Network Connection Unavailable error screen.

Categories

(Core :: Graphics: Layers, defect)

30 Branch
ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED WORKSFORME
blocking-b2g 1.4+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.4 --- affected

People

(Reporter: jmitchell, Assigned: cwiiis)

Details

(Keywords: regression, Whiteboard: burirun1.4-2)

Attachments

(5 files)

Attached file logcat.txt
Description:
When encountering a Network connection unavailable error screen such as on the Youtube app (screenshot 1) and selecting "Try Again", the user encounters a persistant white screen. (screenshot 2). 
note - if they hold down the home button to bring up the task manager the correct error message is shown on the task manager panel (screenshot 3) and not the white screen. 
*not specific to youtube, occurs on any app with the Network Connection unavailable error message such as twitter and facebook as well as the browser.

Repro Steps:
1) Updated Buri to BuildID: 20140324000202
2) Download and launch YouTube app (must be fresh load or it will attempt to use cached data and you might not encounter the connection error message)
3) Turn off Wi-Fi and data
4) Launch the YouTube app
5) Select Retry when you encounter the error message

Actual:
a white screen is encountered

Expected:
the same error message will be shown (after a brief white screen flash)

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140324000202
Gaia: 730670951e40b2317a167fcd07c398bb662d6e87
Gecko: a44f8b39c2c8
Version: 30.0a2
Firmware Version: v1.2-device.cfg

Repro frequency: 9/10
Link to failed test case: https://moztrap.mozilla.org/manage/case/5921/
See attached: logcat.txt Screenshot1.png, Screeshot2.png, Screenshot3.png
Attached image Screenshot1.png
Attached image Screenshot2.png
Attached image Screenshot3.png
This issue does not repro on the Buri version 1.3 Moz Ril 

1.3 Environmental Variables:
Device: buri 1.3 MOZ
BuildID: 20140318004002
Gaia: 2ea2aab306bd1c941719160cdcb49ee9d755dc17
Gecko: cf2042938526
Version: 28.0
Firmware Version: v1.2-device.cfg

No whitescreen is encountered when tapping retry
blocking-b2g: --- → 1.4?
Component: Gaia::Browser → Gaia::System::Window Mgmt
Priority: P3 → --
Whiteboard: burirun1.4-2 → burirun1.4-2 [systemsfe]
QA Contact: mvaughan
Gregor,

Please help investigate and reassign.
blocking-b2g: 1.4? → 1.4+
Flags: needinfo?(anygregor)
Component: Gaia::System::Window Mgmt → Gaia::System
Flags: needinfo?(anygregor)
All my code was landed on master for 2.0 but AFAIK in 1.4 if users click on "Try again" this code is performed

https://github.com/mozilla-b2g/gaia/blob/v1.4/apps/system/js/net_error.js#L291

In that case, the page is reloaded but, as the device is offline, the error UI should be displayed again after a brief white screen flash. If the white screen persists maybe the bug is on Gecko.
TINDERBOX:
- Last Working -
v1.4 Environmental Variables:
Device: Buri ENG v1.4 MOZ RIL
BuildID: 20140310141048
Gaia: a351fe62c11737c722ad33aaff438f6ccd00bd4a
Gecko: 41d962d23e81
Version: 30.0a1
Firmware Version: v1.2-device.cfg

- First Broken -
Device: Buri ENG v1.4 MOZ RIL
BuildID: 20140311122009
Gaia: a351fe62c11737c722ad33aaff438f6ccd00bd4a
Gecko: 9cdaf3f7c601
Version: 30.0a1
Firmware Version: v1.2-device.cfg


**This looks to be a gecko issue**
last working gaia/first broken gecko = REPRO
Gaia: a351fe62c11737c722ad33aaff438f6ccd00bd4a
Gecko: 9cdaf3f7c601

first broken gaia/last working gecko = NO REPRO
Gaia: a351fe62c11737c722ad33aaff438f6ccd00bd4a
Gecko: 41d962d23e81

Push log: http://hg.mozilla.org//mozilla-central/pushloghtml?fromchange=41d962d23e81&tochange=9cdaf3f7c601


MOZILLA INBOUND:
- Last Working -
Device: Buri ENG v1.4 MOZ RIL
BuildID: 20140310192240
Gaia: a351fe62c11737c722ad33aaff438f6ccd00bd4a
Gecko: cafc246cc62c
Version: 30.0a1
Firmware Version: v1.2-device.cfg

- First Broken -
Device: Buri ENG v1.4 MOZ RIL
BuildID: 20140310204542
Gaia: a351fe62c11737c722ad33aaff438f6ccd00bd4a
Gecko: c234a1aeaeab
Version: 30.0a1
Firmware Version: v1.2-device.cfg

Push log: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=cafc246cc62c&tochange=c234a1aeaeab
Blocks: can-tiles
Component: Gaia::System → Graphics: Layers
Product: Firefox OS → Core
Version: unspecified → 30 Branch
Looks like this is a tiling regression.
Let's start with Chris, continue with Jeff/Benoit to cover multiple time zones.
Assignee: nobody → chrislord.net
Whiteboard: burirun1.4-2 [systemsfe] → burirun1.4-2
Things work as expected here :/ I notice the Gecko version stated as broken is 30, but m-c is 31, right? Could the tester try this again with a recent build of Gecko from central?
Flags: needinfo?(jmitchell)
Keywords: qawanted
(In reply to Chris Lord [:cwiiis] from comment #10)
> Things work as expected here :/ I notice the Gecko version stated as broken
> is 30, but m-c is 31, right? Could the tester try this again with a recent
> build of Gecko from central?

This issue does *not* reproduce on the 03/27/14 Master 1.5 build on a Buri. 

Device: Buri Master v1.5 MOZ RIL
BuildID: 20140327040202
Gaia: 9da1b9c11bf518bce882be305ae121c44c5d1e05
Gecko: 9afe2a1145bd
Version: 31.0a1
Firmware Version: v1.2-device.cfg
Flags: needinfo?(jmitchell)
Keywords: qawanted
Attached image 1.4/master(1.5)
As it was mentioned above master indeed has different design - see screenshot

Also, this issue no longer occurs on 1.4 either. 
I've retested it myself and confirmed with the reporter. 

So, looks like this bug can be WFM.

master:
BuildID: 20140327040202
Gaia: 9da1b9c11bf518bce882be305ae121c44c5d1e05
Gecko: 9afe2a1145bd
Version: 31.0a1

v1.4
BuildID: 20140327074806
Gaia: 7d716de0c186416b5b123baa1f3242e23d50529b
Gecko: 69e896713b11
Version: 30.0a2
No longer blocks: can-tiles
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.