Closed Bug 98806 Opened 20 years ago Closed 20 years ago

if background is the first parameter of <td> the image is not displayed

Categories

(SeaMonkey :: General, defect)

PowerPC
Mac System 9.x
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 91034

People

(Reporter: olivier, Assigned: asa)

Details

if background is the first parameter of <td> the image is not displayed, in our
example "Basic Tables" just switch the two parameters of the <td> with
background and the background is not displayed
Reporter, what build are you using?
Also, reporter, there is no URL or attachment to this bug related to your "Basic Tables."
in the example "resource:///res/samples/test3.html" (menu Debug, Viewer Demos,
#3 Basic Tables) if you switch background and rowspan in the cell with a
background image, the background image is not displayed
the bug is present on mozilla 0.9.3 build id: 2001080214 (macos)
the bug is not present on mozilla 0.9.2 (macos)
the bug is not present on mozilla 0.9.3 (windows98)

you can test one of my pages :

http://accessmoto.dyndns.org/bt_accueil?ca.catalogue=road
good on 0.9.2 and 0.9.3 windows but not good on 0.9.3 MacOS9
Since the bug is reported for Mac 0.9.3, this is probably a duplicate of bug 91034. I'm 
going to mark it as such for now. Reporter, please retest with a recent Mac nightly and if 
you can still reproduce don't hesitate to reopen this.

*** This bug has been marked as a duplicate of 91034 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
i try to understand the link with the other bug but this one has nothing linked
to the css, my mac is a newone (G4 733) it's so easy to reproduce the bug

<td rowspan=5 background=bg.jpg> works well in 0.9.2 and 0.9.3

<td background=bg.jpg rowspan=5> works well in 0.9.2 and not in 0.9.3(the image
is not displayed)

only on macos (G4 733/MacOS 9.2.1-Fr)

you can compare on 0.9.2 and 0.9.3, it's very different :

http://accessmoto.dyndns.org/4DCGI/bt_home?ca.catalogue=road
It's the background attribute of the table that doesn't work. That seems to be
done by the same code that is used for CSS, but I guess this isn't clear for
everyone. I had the same problem with my website on 0.9.3, but it's gone in the
latest builds (0.9.4 is fine)

As a workaround for 0.9.3 browsers, you can define an additional bgcolor for the
table : <td bgcolor="#CCCCCC" background=bg.jpg rowspan=5>

This bgcolor will NOT be displayed, but it shows the real background now. I
haven't really tried it with your website (the rowspan attribute), but this did
the trick for mine Example : http://www.bluesweb.org/clubInfo.phtml/crossroads :
each table should have a grey background in the title. Without the (useless)
bgcolor attribute, it will be transparent.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.