Closed Bug 988139 Opened 6 years ago Closed 6 years ago

[b2g][tarako] In phone call, can't switch back to bt sco after switch to speaker

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3T verified)

VERIFIED FIXED
1.4 S5 (11apr)
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- verified

People

(Reporter: xwaynec, Assigned: arthurcc)

Details

(Keywords: regression, Whiteboard: [tarako_only])

Attachments

(1 file)

1. Connect a bt device
2. make a MT call
3. pick up the phone and BT is ok
4. switch to speaker and then switch back
5. BT device doesn't work
Assignee: nobody → arthur.chen
Hi Arthur,

As we talk, please help to fix in 1.3t.
Thanks


Sincerely,
Wayne
Please cherry-pick 1.3 patch to v1.3t.
blocking-b2g: --- → 1.3T?
Etienne, this is a v1.3t only bug. Could you help review the patch? Thanks.
Attachment #8396925 - Flags: review?(etienne)
Triage: seem like a regression for tarako only
ni? Rik as Etienne's on PTO
blocking-b2g: 1.3T? → 1.3T+
Flags: needinfo?(anthony)
Keywords: regression
Whiteboard: [tarako_only]
Comment on attachment 8396925 [details]
link to https://github.com/mozilla-b2g/gaia/pull/17626

Before r+ing this, I'd like to know why we got this regression. This looks like a bad uplift and that might cause other regressions.
Attachment #8396925 - Flags: review?(etienne) → review?(anthony)
Flags: needinfo?(anthony)
Comment on attachment 8396925 [details]
link to https://github.com/mozilla-b2g/gaia/pull/17626

The fix looks good but we need a test to make sure we don't regress again. I can see other uplifts to 1.3t that would get rid of that line again because master doesn't have it anymore.
Attachment #8396925 - Flags: review?(anthony) → review-
Comment on attachment 8396925 [details]
link to https://github.com/mozilla-b2g/gaia/pull/17626

As "settings" is not exposed, I turned to add tests for turnSpeakerOn and turnSpeakerOff.
Attachment #8396925 - Flags: review- → review?(anthony)
Comment on attachment 8396925 [details]
link to https://github.com/mozilla-b2g/gaia/pull/17626

r=me if you remove the changes in apps/system/js/window_manager.js

Thanks!
Attachment #8396925 - Flags: review?(anthony) → review+
ni? Ying for uplift to 1.3T
Flags: needinfo?(ying.xu)
I see some jslint errors.
Is that Ok to proceed?
I don't see linter errors on https://travis-ci.org/mozilla-b2g/gaia/builds/21652779. Just keyboard errors so unrelated to dialer. I think it's ok to proceed.
Arthur, seem like you are actively working on this so i will mark the target milestone to 1.4 S5. please change it if you think otherwise. Thanks
Target Milestone: --- → 1.4 S5 (11apr)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Verified fixed on the Tarako v1.3T MOZ ril.

Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140602014001
Gaia: 335486c42498fa7a93c21e4d6121199728602ab8
Gecko: 55e4d83019e5
Version: 28.1
Firmware Version: SP6821a-Gonk-4.0-4-29

Bluetooth device functions as expected.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.