Closed Bug 988261 Opened 7 years ago Closed 7 years ago

[System] When user presses right arrow in utility tray while Cost Control app is in the foreground, the utility tray does not close

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
Windows 7
defect
Not set
normal

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed, b2g-v2.0 fixed)

VERIFIED FIXED
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: lolimartinezcr, Assigned: alive)

Details

(Keywords: regression, Whiteboard: burirun1.4-2)

Attachments

(2 files)

Attached video VID_0022.3gp
1.4
Platform version: 30.0a2
Build ID: 20140325101236
Git commit: b09bf796
Reproducible: 100%

Tested with an SIM card without billing support

STR:
1) Tap Usage application
2) Tap in utility tray
3) Tap in right arrow

Actual result:
Thiw arrow doesnt' work

Expected result:
Close utility tray and you see usage aplication (not in background)

See video attached
Whiteboard: burirun1.4-2
Summary: When user presses right arrow in utility try, it doesnt' work → [Cost Control] When user presses right arrow in utility try, it doesnt' work
Hi,

Tested on today's master build (3/26) and the same behavior occurs:
Device:hamachi
BuildId: 20140326065930
Gecko: 618b2c2
Gaia: 0c9701c
Platform version: 31.0a1


however, it is properly working on today's (3/26) v1.3 build:
Device:hamachi
BuildId: 20140326055947
Gecko: 6a9a53d
Gaia: 812838a
Platform version: 28.0
so adding regression keyword and nominating to v1.4?
Assignee: nobody → mri
blocking-b2g: --- → 1.4?
Keywords: regression
Summary: [Cost Control] When user presses right arrow in utility try, it doesnt' work → [Cost Control] When user presses right arrow in utility try being CC app opened, nothing happens
Hi, 
This is a system bug, this bug is produced by the file 'system/js/app_window_manager.js', only affects to 1.4 and master. 

The real bug is that the utility tray is not hidden when the CC app is the current application. The STR to reproduces is the following:
1. Open CC application
2. Without minimize, open the utility try
3. Press on the Costcontrol widget

Expected:
The utility tray is closed

Current:
Nothing happen


I thought the problem could be here:
https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/app_window_manager.js#L97

      } else if (appCurrent.instanceID == appNext.instanceID) {
        // Do nothing.
        console.warn('the app has been displayed.');
        return;
      }

The utility tray needs something to know that it has to close.

Regards
Assignee: mri → nobody
Component: Gaia::Cost Control → Gaia::System
Flags: needinfo?(alive)
Component: Gaia::System → Gaia::System::Window Mgmt
blocking-b2g: 1.4? → 1.4+
Component: Gaia::System::Window Mgmt → Gaia::System
The application is working as expected. When tapping on the arrow, the application is not displayed because because it is already displayed. Indeed, if you add a step in the STR and follow this other:

1. Open Cost Control application
2. Press home button to send CC app to the background. !!
3. Show utility tray
4. Tap on the arrow

You will see how the application regain focus again.

The described behaviour is a Window Manager side effect. It is the Window Manager who is in charge of closing the utility tray and showing the app. As the WM see the application is already in foreground it does nothing (which is not entirely true because if you have a full CC application you will see how the proper tab focus depending on which area you pressed).
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
Wooo, sorry, sorry, sorry. I closed this very fast not noticing the component was already changed. I'm rewording the description to avoid future errors.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Summary: [Cost Control] When user presses right arrow in utility try being CC app opened, nothing happens → [System] When user presses right arrow in utility tray while CC app is in the foreground, the utility tray does not close
Summary: [System] When user presses right arrow in utility tray while CC app is in the foreground, the utility tray does not close → [System] When user presses right arrow in utility tray while Cost Control app is in the foreground, the utility tray does not close
QA Contact: jschmitt
The bug does NOT repro on the latest 1.3. This regression window is from the master branch around the branching of 1.3-1.4.

Nightly build:

Last Working:
Environmental Variables:
Device: Buri
BuildID: 20131210040206
Gaia: c952e2756c03eceb4de6a3eba15651741a62f9e8
Gecko: df82be9d89a5
Version: 29.0a1
Firmware Version: V1.2-device.cfg

First Broken:
Environmental Variables:
Device: Buri
BuildID: 20131211040203
Gaia: 6415b8b44068596404c10365394544e94edd5ce5
Gecko: 12ea03a70243
Version: 29.0a1
Firmware Version: V1.2-device.cfg

Last Working Gecko First Broken Gaia: Issue DOES repro
Gaia: 6415b8b44068596404c10365394544e94edd5ce5
Gecko: df82be9d89a5

First Broken Gecko Last Working Gaia: Issue does NOT repro
Gaia: c952e2756c03eceb4de6a3eba15651741a62f9e8
Gecko: 12ea03a70243

Gaia Pushlog:

https://github.com/mozilla-b2g/gaia/compare/c952e2756c03eceb4de6a3eba15651741a62f9e8...6415b8b44068596404c10365394544e94edd5ce5

For error checking, Gecko Pushlog:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=df82be9d89a5&tochange=12ea03a70243
Thanks :mai, taken
Assignee: nobody → alive
Flags: needinfo?(alive)
Attachment #8397584 - Flags: review?(timdream) → review+
https://github.com/mozilla-b2g/gaia/commit/3a6a4f0cf2cca642579f742d5f4f7ab589ae86d2
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
tested and working
1.5 
Gecko fa7c5ad
Gaia 7c73c66

1.4
Gecko a15cb07
Gaia 441c4bc
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.