Closed Bug 988269 Opened 6 years ago Closed 5 years ago

[Messages][Refactoring] Investigate whether ActivityHandler.isLocked is still required (follow up from bug 936729)

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: azasypkin, Assigned: azasypkin)

References

Details

(Whiteboard: [sms-sprint-2.2S4])

Attachments

(1 file)

Investigate whether ActivityHandler.isLocked is still required for the 'new' and 'share' activity. Get rid of it in case we don't need it anymore.
Summary: [Messages] Investigate whether ActivityHandler.isLocked is still required (follow up from bug 936729) → [Messages][Refactoring] Investigate whether ActivityHandler.isLocked is still required (follow up from bug 936729)
Let's finally deal with this :)
Assignee: nobody → azasypkin
Status: NEW → ASSIGNED
Attachment #8549195 - Flags: review?(felash)
Whiteboard: [sms-sprint-2.2S4]
Comment on attachment 8549195 [details] [review]
GitHub pull request URL

Hey Steve, can you please have a look at this simple patch? Thanks !
Attachment #8549195 - Flags: review?(felash) → review?(schung)
Comment on attachment 8549195 [details] [review]
GitHub pull request URL

Thanks for the clean up, I think we don't need this since all the new activity is inline now. BTW I discover an edge case unrelated to this patch(related to new activity) will lead the message app crashed:

1) Contact -> detail -> send message -> Back to home at compose panel
2) Phone -> switch to contact tab -> send another message from contact
3) Message app crashed

It's not related to the patch because it just crashed without reaching the activity-handler at second time. Just wondering if you could reproduce this as well.
Attachment #8549195 - Flags: review?(schung) → review+
Hi Alive, we discover a crash issue in comment 3. Is there any known issue about calling new inline activity repeatedly?
Flags: needinfo?(alive)
(In reply to Steve Chung [:steveck] from comment #4)
> Hi Alive, we discover a crash issue in comment 3. Is there any known issue
> about calling new inline activity repeatedly?

https://bugzilla.mozilla.org/show_bug.cgi?id=931339 ?
System app should kill the first activity before the second activity chaining starts, but I suspect it failed to understand the second contact is not the first contact..
Flags: needinfo?(alive)
(In reply to Steve Chung [:steveck] from comment #3)
> Comment on attachment 8549195 [details] [review]
> GitHub pull request URL
> 
> Thanks for the clean up, I think we don't need this since all the new
> activity is inline now. BTW I discover an edge case unrelated to this
> patch(related to new activity) will lead the message app crashed:
> 
> 1) Contact -> detail -> send message -> Back to home at compose panel
> 2) Phone -> switch to contact tab -> send another message from contact
> 3) Message app crashed
> 
> It's not related to the patch because it just crashed without reaching the
> activity-handler at second time. Just wondering if you could reproduce this
> as well.

Yep, I see the same issue and looks like it's related to bug 931339 - when we open Messages as inline activity the second time it doesn't receive "activity" system message at all and we can stuck in half-initialized app. And it seems in my case the first activity instance crashed.
Thanks for review! Treeherder is green except for one unrelated and known intermittent.

Master: https://github.com/mozilla-b2g/gaia/commit/2e22ab55444c418410a7eb4a1a044834777566b9
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.