Closed Bug 988370 Opened 6 years ago Closed 6 years ago

Regression: position: fixed element corruption when panning

Categories

(Firefox for Android :: Toolbar, defect)

30 Branch
All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox30 --- verified
firefox31 --- verified
fennec 30+ ---

People

(Reporter: u421692, Assigned: cwiiis)

References

Details

(Keywords: regression, reproducible)

Attachments

(2 files)

Environment:
Build:Nightly 31.0a1(2014-03-26)
Device:LG Nexus 4(Android 4.4.2)/Alcatel One Touch 8008D(Android 4.1.2)

Steps to reproduce:
1. Go to FF marketplace
2. Scroll the app list

Expected result:
Scrolling is performed without any issues

Actual result:
You can see visual artifacts of the Marketplace search bar
Attached video marketplace2.mp4
Reproducible on my Nexus 5 (4.4.2)

Chris?

Last good revision: 72c2f9ebf4bc (2014-03-22)
First bad revision: c3b840de1f7b (2014-03-23)

Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=72c2f9ebf4bc&tochange=c3b840de1f7b

fef29327a1b1	Chris Lord — Bug 983208 - Fix progressive tile update calculations.
tracking-fennec: --- → ?
Component: Web Apps → Graphics, Panning and Zooming
QA Contact: aaron.train
Summary: Scrolling in the Firefox marketplace results in visual artifacts of the Marketplace search bar → Regression: fixed position search bar tile on Firefox Marketplace enters a low-res state (new) on scroll and does not resolve
Blocks: 983208
Duplicate of this bug: 988040
General issue re: position: fixed element corruption when panning
Summary: Regression: fixed position search bar tile on Firefox Marketplace enters a low-res state (new) on scroll and does not resolve → Regression: position: fixed element corruption when panning
Version: Firefox 31 → Firefox 30
tracking-fennec: ? → 30+
Assignee: nobody → chrislord.net
I think this will be fixed by bug 983169, but at the same time, we shouldn't be using progressive rendering/low precision rendering on fixed position content, so I'm going to use this bug to track that and fix that.
So fixed layers ought to always be clipped to the viewport during display list creation, so I think it's ok to just disable progressive/low-res rendering like this, even if there's a display-port.
Attachment #8398442 - Flags: review?(matt.woodrow)
Attachment #8398442 - Flags: review?(matt.woodrow) → review+
Pushed to inbound: https://hg.mozilla.org/integration/mozilla-inbound/rev/c5a753c7a84a
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/c5a753c7a84a
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Comment on attachment 8398442 [details] [diff] [review]
Disable progressive and low precision rendering on fixed layers

[Approval Request Comment]
Bug caused by (feature/regressing bug #): This bug
User impact if declined: Weird rendering glitches with position:fixed content
Testing completed (on m-c, etc.): Locally and now on m-c
Risk to taking this patch (and alternatives if risky): Low. Selectively disables a feature.
String or IDL/UUID changes made by this patch: None.
Attachment #8398442 - Flags: approval-mozilla-aurora?
Attachment #8398442 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed on:
Builds:
32.0a1 (2014-05-09)
31.0a2 (2014-05-09)
30.0

Devices:
Galaxy Nexus (Android 4.2.1)
Asus Transformer Pad TF300T (Android 4.2.1)
Galaxy Nexus 5 (Android 4.4.2)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.