Closed Bug 988561 Opened 6 years ago Closed 6 years ago

jit-test/tests/basic/testBug686274.js is slow with non-default JIT flags

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla31

People

(Reporter: jandem, Assigned: jandem)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

time dbg32/js jit-test/tests/basic/testBug686274.js
real	0m3.225s
user	0m3.213s
sys	0m0.037s

time dbg32/js --baseline-eager jit-test/tests/basic/testBug686274.js
real	0m18.195s
user	0m18.044s
sys	0m0.169s

The problem is that this test has a function with a huge array literal (1 million elements) and executes it only once. This is kind of worst-case behavior for Baseline.

Also, 18 seconds on a very fast Mac, on most machines it will probably be slower.
Attached patch PatchSplinter Review
Don't baseline-compile this function with --baseline-eager as it's very slow in debug builds.
Assignee: nobody → jdemooij
Status: NEW → ASSIGNED
Attachment #8397391 - Flags: review?(luke)
Comment on attachment 8397391 [details] [diff] [review]
Patch

Hah
Attachment #8397391 - Flags: review?(luke) → review+
https://hg.mozilla.org/mozilla-central/rev/e1f47e027885
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
You need to log in before you can comment on or make changes to this bug.