Some actions associated with icons don't work

VERIFIED DUPLICATE of bug 73186

Status

()

VERIFIED DUPLICATE of bug 73186
17 years ago
17 years ago

People

(Reporter: r-scott.butler, Assigned: rogerl)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
At the bottow of the page references by the URL associated with this report
there are three icons: "email this!", "print this!", "save this!". Clicking on
the print button causes a page to be generated that is formated for printing. 
If, however, you click on the other two icons, nothing happens at all. There is
no error, noaction, no nothing.

General comment/request:

I am using Mozilla .93 as my default browser and mostly it works well. However,
about once a every couple of days, I find a page that such as the one above
where something just plain doesn't work.  My question is this: How can I collect
the most information to forward to mozilla.org to help in figuring out what the
problem is? Is there some way to force a craah so that a 'talkback' dump will be
generated and sent?

I desperately want to find an alternative to IE but every now and then have to
use it to get something done.

How can I help?
Evangelism.... Clicking on the save button calls:

openWindow( .... )   // url very long, so leaving it out.

We also have:

var isNav4, isIE4, isNav3, isIE3
if (navigator.appVersion.charAt(0) == "4") {
  if (navigator.appName == "Netscape") {
    isNav4 = true;
  } else {
    isIE4 = true;
  }
} else if (navigator.appVersion.charAt(0) == "3") {
  if (navigator.appName == "Netscape") {
    isNav3 = true;
  } else {
    isIE3 = true;
  }
}

function openWindow(url, name, rs, sc, w, h) {
  if (isNav3 || isNav4 || isIE4) {
     // do stuff 
  } else {
      return true;
  }
}

So openWindow() does nothing in Mozilla.  I'm not even sure it works in IE5; I
guess that depends on what IE5 reports as appVersion.

And as it happens we have this filed already....

*** This bug has been marked as a duplicate of 73186 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
> How can I help?

Mail zdnet and tell them their JS should be checking for browser versions >=4
instead of just ==4.  :)

Comment 3

17 years ago
Verified Duplicate -

r-scott.butler@usa.dupont.com: thank you for this report; you have 
been cc'ed on the other bug, so you can follow its progress.

You may be interested to see what the Evangelism component does.
It tracks websites like this that use HTML or JavaScript that is 
non-compliant with W3C standards. 

You can see all open Evangelism bugs by using the Bugzilla query page: 

            http://bugzilla.mozilla.org/query.cgi

Choose "Status" = "UNCONFIRMED" + "NEW" + "ASSIGNED" + "REOPENED"
Choose "Program" = "Tech Evangelism"
Choose "Component" = "US English", for example
Click on "Submit"


This produces a query like this:

http://bugzilla.mozilla.org/buglist.cgi?bug_status=UNCONFIRMED&bug_status=NEW&bu
g_status=ASSIGNED&bug_status=REOPENED&email1=&emailtype1=substring&emailassigned
_to1=1&email2=&emailtype2=substring&emailreporter2=1&bugidtype=include&bug_id=&c
hangedin=&votes=&chfieldfrom=&chfieldto=Now&chfieldvalue=&product=Tech+Evangelis
m&component=US+English&short_desc=&short_desc_type=allwordssubstr&long_desc=&lon
g_desc_type=allwordssubstr&bug_file_loc=&bug_file_loc_type=allwordssubstr&status
_whiteboard=&status_whiteboard_type=allwordssubstr&keywords=&keywords_type=anywo
rds&field0-0-0=noop&type0-0-0=noop&value0-0-0=&cmdtype=doit&newqueryname=&order=
Reuse+same+sort+as+last+time
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.