Closed Bug 988715 Opened 6 years ago Closed 6 years ago

Update MP4Reader demuxer to support non fragmented MP4 and seeking

Categories

(Core :: Audio/Video, defect)

29 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 908503

People

(Reporter: cpearce, Unassigned)

Details

The MP4 demuxer used by MP4Reader (chromium's) currently only handles fragmented MP4 which conform to the MSE constraints. We'd like to use the MP4Reader for all MP4 playback, so that we have better control over the threading and seeking, and more consistent behaviour across platforms.

One solution would be to use android's demuxer from libstagefright. Another solution would be adding code to our existing demuxer to make it handle the things we want it to.

The advantage of using Android's demuxer is that it also has code to supports the other format's we're interested in on mobile, like MP3, H.263, 3GP, etc.

Ideally if we import a new demuxer, it would be good if we could do it with as few code changes a possible, to make updating it from upstream easier.
Oh oops, I already filed this one ;)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 908503
You need to log in before you can comment on or make changes to this bug.