Right click selectes entire table cell in composer

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: jacekf, Assigned: cmanske)

Tracking

Trunk
mozilla0.9.6
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE (1 day))

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I am in a cell in a table and enter some text into it.
Then, I want to insert another table within the same cell, beneath the text I've
already entered. 
Right-clicking the place where I want to insert the table selects the contents
of the entire cell. I then do "Table insert" and it inserts the table, but since
the entire cell was highlighted it utterly replaces its contents with the new
table instead of adding it to it.
Doing it via the menu (i.e. Insert -> Table ) works fine.
(Reporter)

Comment 1

17 years ago
Created attachment 48696 [details]
sample test page
(Reporter)

Comment 2

17 years ago
In the sameple test page, go to the 2 cell in the second row.

Underneath the line where it says "Introducing the finest POS touchscreen
solution in the industry:" try rightclicking and inserting a table. You can't,
it will select the entire cell and when inserting a new table remove the
existing text in that cell (i.e. ""Introducing the finest POS touchscreen
solution in the industry:")
Editor, not compositor
Assignee: kmcclusk → brade
Component: Compositor → Editor
QA Contact: petersen → sujay

Comment 4

17 years ago
-->cmanske
Assignee: brade → cmanske
Target Milestone: --- → mozilla0.9.6
(Assignee)

Comment 5

17 years ago
The "entire cell" is not being selected, but all of the contents are, but only
if you right-click in the area outside of those contents. If you click inside
the contents, we don't select everything.
(I thought this was fixed!)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

17 years ago
spam composer change
Component: Editor: Core → Editor: Composer
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Whiteboard: EDITORBASE (1 day)
(Assignee)

Comment 7

17 years ago
Well, I know this was fixed before, and now it seems to be working correctly 
again. I suspect some other problem occured and is now fixed, so this was fixed 
as well.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 8

17 years ago
marking verified...reporter, if you can reproduce, then REOPEN.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.