Closed Bug 988851 Opened 7 years ago Closed 5 years ago

Add HWC's support to TiledContentHost

Categories

(Core :: Graphics: Layers, defect)

Other
Other
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
tracking-b2g backlog

People

(Reporter: sotaro, Assigned: sotaro)

Details

+++ This bug was initially created as a clone of Bug #988511 +++

This bug is created based on Bug 988511 Comment 9. When tiling is used for rendering, HWC is not used for composition. It is better to continue to use HWC even when tiling is used.
Change around TiledContentHost::GetRenderState() and HwcComposer2D::PrepareLayerList() seems necessary.
blocking-b2g: --- → 1.5?
I'm not convinced we need to worry about ICS devices and their HWC limits, so lets first concentrate on JB and later.
No new features for ICS please. Also, I wouldn't block on this. I would put this in the backlog. Happy to have it, not blocking.
Backlog per comment 3.
blocking-b2g: 2.0? → backlog
Assignee: nobody → sotaro.ikeda.g
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 986381
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
blocking-b2g: backlog → ---
The use case becomes invalid.
Status: REOPENED → RESOLVED
Closed: 7 years ago5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.