Closed Bug 988889 Opened 8 years ago Closed 8 years ago

Regression: Reader toolbar's font panel not displaying properly

Categories

(Firefox for Android Graveyard :: Toolbar, defect)

31 Branch
ARM
Android
defect
Not set
normal

Tracking

(firefox30 verified, firefox31 verified, fennec30+)

VERIFIED FIXED
Tracking Status
firefox30 --- verified
firefox31 --- verified
fennec 30+ ---

People

(Reporter: paul.feher, Unassigned)

References

Details

(Keywords: regression, reproducible)

Build:Nightly 31.0a1 (2014-03-27),
Device: LG Optimus 4X HD (4.1.2)

Steps to reproduce:
1. Open any article in reader mode.
2. Invoke the reader-mode toolbar
3. Try to access the fonts panel

Expected Results: 
The font panel is displayed.

Actual Results:
The font panel isn't displayed.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
This is still reproducible on following devices using the latest Nightly 31.0a1 (2014-03-28)
Aurora 30.0a2 (2014-03-28)
Nexus 4 (Android 4.4.2)
LG Optimus 4X (Android 4.1.2)
Alcatel One Touch (Android 4.1.2)

Aaron can you specified on which device you tested?
Status: RESOLVED → REOPENED
Flags: needinfo?(aaron.train)
Resolution: WORKSFORME → ---
Was on an old build, whoops. I do see this.

Last good revision: 72c2f9ebf4bc (2014-03-22)
First bad revision: c3b840de1f7b (2014-03-23)

Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=72c2f9ebf4bc&tochange=c3b840de1f7b

fef29327a1b1	Chris Lord — Bug 983208 - Fix progressive tile update calculations. r=botond

Chris, dupe of the other recently filed regressions?
Blocks: 983208
Status: REOPENED → NEW
tracking-fennec: --- → ?
Component: Reader Mode → Graphics, Panning and Zooming
Flags: needinfo?(aaron.train) → needinfo?(chrislord.net)
Summary: Reader mode font panel is not displayed → Regression: Reader toolbar's font panel not displaying properly
(In reply to Aaron Train [:aaronmt] from comment #2)
> Was on an old build, whoops. I do see this.
> 
> Last good revision: 72c2f9ebf4bc (2014-03-22)
> First bad revision: c3b840de1f7b (2014-03-23)
> 
> Pushlog:
> https://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=72c2f9ebf4bc&tochange=c3b840de1f7b
> 
> fef29327a1b1	Chris Lord — Bug 983208 - Fix progressive tile update
> calculations. r=botond
> 
> Chris, dupe of the other recently filed regressions?

Yes, I expect this is a dupe of bug 988370.
Flags: needinfo?(chrislord.net)
Paul, can you reproduce this still with bug 988370 fixed?
Flags: needinfo?(paul.feher)
The issue seems to be fixed by bug 988370 on latest Nightly
Flags: needinfo?(paul.feher)
Status: NEW → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → WORKSFORME
Can we retest on Fx30 and marked fixed there too?
Flags: needinfo?(aaron.train)
I am not able to reproduce this anymore on Firefox for Android 30.0a2 (2014-04-03) on LG Nexus 4 (Android 4.4.2)
tracking-fennec: ? → 30+
Flags: needinfo?(aaron.train)
Verified as fixed in build: 31.0a1 (2014-04-14)
Device: Nexus 4 (Android 4.4.2)

Based on Teodora's comment7 I will mark this bug as verified fixed.
Status: RESOLVED → VERIFIED
Resolution: WORKSFORME → FIXED
Verified as fixed in build 30.0a2 (2014-04-17);
Device: Google Nexus 4 (Android 4.4.2).
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.