Ion-compile scripts containing arrow functions

RESOLVED FIXED in mozilla31

Status

()

defect
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: jandem, Assigned: jandem)

Tracking

unspecified
mozilla31
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

5 years ago
Right now IonBuilder aborts if we have a JSOP_LAMDBA for an arrow function. Fix coming up.
Assignee

Updated

5 years ago
Depends on: 989011
Assignee

Comment 1

5 years ago
Posted patch PatchSplinter Review
Adds MLambdaArrow, just like MLambda, except that it takes the lexical |this| value and stores it in the clone's extended slot.
Attachment #8403464 - Flags: review?(bhackett1024)
Attachment #8403464 - Flags: review?(bhackett1024) → review+
Assignee

Comment 3

5 years ago
And FWIW, green Linux x64 Try run: https://tbpl.mozilla.org/?tree=Try&rev=65f18e6af1bf
https://hg.mozilla.org/mozilla-central/rev/5e5711c0cc1d
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
Assignee

Updated

5 years ago
Depends on: 999358
Duplicate of this bug: 851913
You need to log in before you can comment on or make changes to this bug.