Closed Bug 989038 Opened 7 years ago Closed 7 years ago

[Camera]Sometimes I can take pictures with the preview button

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set
blocker

Tracking

(blocking-b2g:1.4+)

RESOLVED WORKSFORME
1.4 S5 (11apr)
blocking-b2g 1.4+

People

(Reporter: marcia, Assigned: ver4ffos)

References

Details

Buri, while running with the latest master.

Gaia   287195d1fed2e6c883745d7091a4c05e56c4dbb7
SourceStamp bb4dd9872236
BuildID 20140327092814
Version 31.0a1

STR:

1. Tap rapidly on the shutter button to take a series of pictures
2. Eventually I can get the camera in a state where I can press the preview button and instead of preview launching, the camera continues to take pictures.

I will try to get a better set os steps, but I have now seen it at least three times.
Blocks: 983405
Youngjun, 

Please assign
Severity: major → blocker
Flags: needinfo?(jjoons79)
Whiteboard: [m+]
Dear Verchaswa,

Can you take this issue?
Flags: needinfo?(jjoons79) → needinfo?(ver4ffos)
Assignee: nobody → ver4ffos
Offline discussion: Verchaswa will be working on this issue.
Flags: needinfo?(ver4ffos)
marcia: unable to reproduce this issue. Perhaps this has since stabalised?
Flags: needinfo?(mozillamarcia.knous)
Sameer from QC says that this is not reproducible because camera click button freezes after multiple back-to-back shots. Can one of you please test that out and address the freeze issue...
Flags: needinfo?(wilsonpage)
I'm not sure exactly what you mean by 'freeze'. The button is designed to stay in its blue 'pressed' state until the shutter sound fires. While it is in this state, photos cannot be taken. This seems to make sense to me.
Flags: needinfo?(wilsonpage)
I'm not sure exactly what you mean by 'freeze'. The button is designed to stay in its blue 'pressed' state until the shutter sound fires. While it is in this state, photos cannot be taken. This seems to make sense to me.
Regarding the original bug, I believe that this behavior occurred while I was experiencing Bug 988632. So it is possible that camera is in a very strange state when I was seeing this bug. Will try to further attempts to get some better STR.
Flags: needinfo?(mozillamarcia.knous)
Marcia to reproduce this without APZ on
Summary: [Camera][Madai] Sometimes I can take pictures with the preview button → [Camera]Sometimes I can take pictures with the preview button
Flags: needinfo?(mozillamarcia.knous)
Please have ver4ffos test this with APZ off and see if the behavior is the same...
Flags: needinfo?(jjoons79)
Today Verchaswa can test it.
Flags: needinfo?(jjoons79)
I tested it for 100 times. Bug do not reproduced.
ver4ffos: Just to be clear, do you mean that with APZ turned off, you cannot reproduce? Is it still reproducible with APZ turned on?
Flags: needinfo?(ver4ffos)
Dear Justin,
1. With APZ turned off and I can not reproduce the bug(as per my above comment).
2. With APZ turned on, I tested few times and I can not reproduce the bug.
Flags: needinfo?(ver4ffos)
blocking-b2g: --- → 1.4+
Dear Marcia,

Is this issue reproduced on Nexus4? We don't have Buri device. 
Please let me know.
Is this still happening on 1.4? 

Thanks
Hema
Keywords: qawanted
Whiteboard: [m+]
(In reply to Youngjun Kim from comment #15)
> Dear Marcia,
> 
> Is this issue reproduced on Nexus4? We don't have Buri device. 
> Please let me know.

I haven't yet been able to reproduce this on Nexus 4. Trying to reproduce on 1.4 now.
Flags: needinfo?(mozillamarcia.knous)
Target Milestone: --- → 1.4 S5 (11apr)
Whiteboard: [close me 4/11]
Reopen if this can be reproduced again.
Status: NEW → RESOLVED
Closed: 7 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
Whiteboard: [close me 4/11]
You need to log in before you can comment on or make changes to this bug.