Talkback does not catch the crash when Mozilla blows the stack

RESOLVED INVALID

Status

--
critical
RESOLVED INVALID
17 years ago
9 years ago

People

(Reporter: andre.bugs2, Assigned: mcafee)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
[Build: 2001-09-04-21 on Linux]

Talkback initializes correctly for me (and I can launch talkback manually) but
when I reproduced the bug #98901 mozilla crashed without talkback catching it. 

To reproduce:

1) Get a talkback enabled build for Linux (I think this is linux-only).
2) Click on the attachment below (which is a .html file from bug #98901)

Result: Talkback should catch the crash.
Expected result: Talkback should catch the crash.

I have seen this happen before, and I even vagely remember posting a comment to
a similar bug before. I could however not find that bug when I searched for it.
(Reporter)

Comment 1

17 years ago
Created attachment 48712 [details]
Open this .html-file in mozilla and watch talkback fail to catch the crash that occurs.
(Reporter)

Comment 2

17 years ago
In case I wasn't clear enough, I see that talkback is initialized on startup:

Hey : You are in QFA Startup 
(QFA)Talkback loaded Ok.
(Reporter)

Comment 3

17 years ago
Sorry for spam, but I noticed I made a typo in my build-ID. It should be
2001-09-07-21.
(Reporter)

Comment 4

17 years ago
Setting severity to major.
Severity: normal → major
(Reporter)

Comment 5

17 years ago
Just to prove that talkback was not completely malfunctioning I killed mozilla
on purpose with "kill -SEGV process-id" and I was presented with a nice shiny
talkback window.
Using 2001091721/linux
When mozilla crashes on www.pointcom.com
(http://bugzilla.mozilla.org/show_bug.cgi?id=100273)
talkback does not catch the crash either.
I get:

(QFA)Talkback loaded Ok.
/home/me/TMP/mozilla-linux/mozilla/run-mozilla.sh: line 72: 20530 Segmentation
fault      $prog ${1+"$@"}
(Reporter)

Comment 7

17 years ago
*** Bug 84628 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 8

17 years ago
I ran into this again today with 2001-12-07-21 on Linux when running chofmann's
browser buster. After almost 400 pages mozilla "finally" crashed, and it was
very frustrating to see talkback NOT catch it.

I think a lot of valuable crash data is getting lost because of this.

Comment 9

16 years ago
The example file does not crash Mozilla 1.3 pre-beta build 2003012908, Windows
98. Does it still crash Linux Mozilla?
Summary: Talkback does not catch this crash even though talkback is active and initialized. → Talkback does not catch this crash even though Talkback is active and initialized

Comment 10

16 years ago
-> mcafee
Assignee: namachi → mcafee

Updated

16 years ago
Severity: major → critical
Keywords: crash
(Assignee)

Comment 11

16 years ago
comment #1 attachment is missing, also missing from bug 98901.
I'll run browser buster here for a while, but this will be hard
to track down.  Any particular versions of linux we're talking about here?
I'm testing this on rh73.

Comment 12

15 years ago
note that the original problem here (not catching the crash in bug 98901) is
because that crash blew the stack (see bug 98901 comment 18).  In that situation
(and a few others), talkback rarely works, but it still works for most crashes.

I don't know if it's even possible to fix something like this or not.
Summary: Talkback does not catch this crash even though Talkback is active and initialized → Talkback does not catch the crash when Mozilla blows the stack

Comment 13

15 years ago
without the talkback source, we're not going to be able to fix talkback bugs
like this.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Updated

9 years ago
Component: Talkback Client → Talkback Client
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.