Closed Bug 989104 Opened 7 years ago Closed 7 years ago

[email] allow for longer module load timeouts for background loads

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
1.4 S4 (28mar)

People

(Reporter: jrburke, Assigned: jrburke)

Details

(Whiteboard: [p=1])

Attachments

(2 files)

64 bytes, text/x-github-pull-request
mcav
: review+
Details | Review
46 bytes, text/x-github-pull-request
mcav
: review+
Details | Review
An issue came up in Clock for Tarako, where the background loading of the alarm entry point was taking a long time, longer than the default 7 seconds used as the timeout for module loading. The fix mcav and I worked out is setting waitSeconds to 7 in DEBUG=1 scenarios, but in a build scenario, changing the value to 0, which means no timeout:

https://github.com/mozilla-b2g/gaia/pull/17587/files

We should probably do the same thing for email, particularly for Tarako and sync cases.
Assignee: nobody → jrburke
Target Milestone: --- → 1.4 S4 (28mar)
Attached file GELAM pull request
Asking mcav for review since he did similar change for clock, but feel free to kick it back if you prefer not to do it.

Confirmed that output ends up with waitSeconds set to 0 for both front and back end, an run on device, still works.
Attachment #8398264 - Flags: review?(m)
Attached file Gaia pull request
Asking mcav for review since he did similar change for clock, but feel free to kick it back if you prefer not to do it.

Confirmed that output ends up with waitSeconds set to 0 for both front and back end, an run on device, still works.
Attachment #8398265 - Flags: review?(m)
Comment on attachment 8398264 [details] [review]
GELAM pull request

It's like deja-vu all over again! :)
Attachment #8398264 - Flags: review?(m) → review+
Comment on attachment 8398265 [details] [review]
Gaia pull request

I was confused for a second at the js/ext file showing 0, but realized it was copied from gelam. Looks ok to me.
Attachment #8398265 - Flags: review?(m) → review+
Some background on that for completeness: I thought it was fine to use 0 for the copied built gelam as those layers are loaded in bulk optimized form inside the worker. Since the worker uses importScripts() which is synchronous, if there were errors, there should be a very obvious error without needing the script timeout in the loader.
Whiteboard: [p=1]
You need to log in before you can comment on or make changes to this bug.