Closed Bug 989113 Opened 7 years ago Closed 7 years ago

[Camera][Madai][Buri] Camera shows black screen after editing a picture in Gallery

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set
blocker

Tracking

(blocking-b2g:1.4+, b2g-v1.4 verified, b2g-v2.0 verified)

VERIFIED FIXED
1.4 S5 (11apr)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- verified
b2g-v2.0 --- verified

People

(Reporter: marcia, Assigned: justindarc)

References

()

Details

(Keywords: regression, Whiteboard: [m+])

Attachments

(1 file)

Buri, while running with the latest master.

Gaia   287195d1fed2e6c883745d7091a4c05e56c4dbb7
SourceStamp bb4dd9872236
BuildID 20140327092814
Version 31.0a1

STR:
1. Enter the Gallery app and select a picture to edit.
2. Press the edit button and select "Auto Enhance On"
3. Press the done button.
4. Press the camera button in the bottom of the screen on the left.

Expected: I could see the camera viewfinder.
Actual: Black screen

Logcat attached.
Can we verify this doesn't happen on 1.4 with the old camera implementation?
Keywords: qawanted
Black screen is also happening from the lockscreen scenario too
Blocks: 983405
Depends on: 988610
Severity: critical → blocker
Whiteboard: [m+]
I have confirmed this as a duplicate of:

Bug 988610 - [Camera][Madai] Black screen when opening camera from lockscreen and camera app isn't open

PR for 988610 is in review now.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 988610
Does NOT occur on latest 1.4.

After brief delay during switch from gallery to camera app the viewfinder appears.

Environmental Variables:
Device: Buri v1.4 Mozilla RIL
BuildID: 20140331000202
Gaia: 4c3b2f57f4229c5f36f0d8fd399e65f4db88f104
Gecko: 3aaca223b673
Version: 30.0a2
Firmware Version: v1.2-device.cfg
Keywords: qawanted
I still see this bug on 1.4 Buri using:

Gaia   26983f356ecb1bcf30e862d334b5de790071803e
SourceStamp 70b076fc7558
BuildID 20140408000202
Version 30.0a2
Base Image: 1.2.cfg

So I don't believe this is a duplicate of Bug 988610 which appears to already have landed on 1.4. Also the STR mention switching to see the viewfinder - this bug is about not seeing the picture in Gallery and doesn't have anything to do with viewfinder,.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
blocking-b2g: --- → 1.4?
I will add that the issue filed in Bug 988610 no longer happens using the same build in Comment 5.
blocking-b2g: 1.4? → 1.4+
Assignee: nobody → jdarcangelo
This may have already been fixed by the patch for Bug 991344 which landed in 1.4. I am unable to reproduce in the latest nightly builds for both 1.4 and 1.5/2.0 (master).

Builds tested:

1.4:
Gaia      9b2da43dfee3792cd311ae55f0b06272313208f0
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/9d9ead7d6afa
BuildID   20140410000201
Version   30.0a2

1.5/2.0:
Gaia      9d0b1bdf746823a94b13e6574c1d8304dc584763
Gecko     https://hg.mozilla.org/mozilla-central/rev/690c810c8e3e
BuildID   20140410040201
Version   31.0a1

Additionally, I'm confused by Marcia's comment 5 saying this bug has nothing to do with the viewfinder. Isn't that what is described in the STR?
Flags: needinfo?(mozillamarcia.knous)
(In reply to Justin D'Arcangelo [:justindarc] from comment #7)
> This may have already been fixed by the patch for Bug 991344 which landed in
[snip]

Justin: It looks like I had so many tabs opened I mistakenly put this comment in the wrong bug - apologies for that. What still happens is Bug 989568, which was duped to another open bug. So this flow does indeed work, and the part of that doesn't still work is covered in the other bug (after you edit a picture in gallery and press the home button the picture doesn't show)
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Flags: needinfo?(mozillamarcia.knous)
Resolution: --- → FIXED
Depends on: 991344
Target Milestone: --- → 1.4 S5 (11apr)
The issue is no longer reproduces on the latest 1.4 and master build.
No black appears when from "Auto Enhance On" navigating back to camera
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Flags: in-moztrap?(rmead)
New test case needs to be added. There is no existing test case.
Test case has been added to moztrap:

https://moztrap.mozilla.org/manage/case/14354/
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: in-moztrap?(rmead)
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.