Scrolled page in Readermode produces banner strip artifact

VERIFIED FIXED in Firefox 30

Status

()

defect
VERIFIED FIXED
6 years ago
3 years ago

People

(Reporter: capella, Assigned: cwiiis)

Tracking

({regression})

unspecified
Firefox 31
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox30 verified, firefox31 verified, firefox32 verified, fennec30+)

Details

Attachments

(1 attachment)

Posted image Reader mode bug.png
Display any page in reader mode, and scroll to the bottom of the page. Scroll / fling up slightly and and the banner is displayed in a tiny little zoomed out style as seen in attachment.
This situation usually happens when changes to position:fixed handling land in the tree.

Chris - Any ideas?
Flags: needinfo?(chrislord.net)
Probably in relation and or duplicate of the other number of regressions we're currently shipping on Aurora and Nightly (bug 988370, bug 988882) as a result of 983208.
tracking-fennec: --- → ?
OS: Linux → Android
Hardware: x86_64 → ARM
Do these still occur after bug 983169? And if so, could you check with the patch on bug 988370?
Flags: needinfo?(chrislord.net) → needinfo?(markcapella)
Bug 983169 didn't help. Bug 988370's patch helps in that I don't see the zoomed-out banner due to new(?) banner behavior...

Scrolling up from any page position exposes the banner strip and leaves it there on successive up-scrolls, where previously up or down scrolls with banner exposed would hide it.
Flags: needinfo?(markcapella)
fyi, that was release I was comparing it to.
Regression window wanted:
1. mozilla-central:
good build: 22-03-2014
bad build: 23-03-2014
pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=72c2f9ebf4bc&tochange=c3b840de1f7b

2. inbound:
good build: 1395475274
bad build: 1395480015 
pushlog:http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=50ae5e011f79&tochange=fef29327a1b1
Blocks: 983208
Fixed? Is still still reproducible with bug 988370 fixed?
Can we retest? This is working now for me.
Flags: needinfo?(aaron.train)
I am not able to reproduce this on LG Nexus 4 (Android 4.4.2) on Firefox for Android 30.0a2 and 31.0a1 (2014-04-03)
Status: NEW → RESOLVED
tracking-fennec: ? → 30+
Closed: 5 years ago
Flags: needinfo?(aaron.train)
Resolution: --- → FIXED
Assignee: nobody → chrislord.net
Depends on: 988370
Target Milestone: --- → Firefox 31
Verified as fixed in:
Build: 30.0a2 (2014-04-07)
Devices: Asus Transformer (Android 4.2.1), Samsung S3 (Android 4.3) and Acer Iconia (Android 3.2.1)
Verified on build:
Nightly (2014-05-08)

Device:
Galaxy Nexus (Android 4.2.1)

and based on Teodora's comment9 I will mark this bug as verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.