Closed Bug 989282 Opened 6 years ago Closed 6 years ago

Add debug mode for detailed inspection of Sync

Categories

(Testing Graveyard :: TPS, defect)

defect
Not set

Tracking

(firefox29 affected, firefox30 fixed, firefox31 fixed)

RESOLVED FIXED
mozilla31
Tracking Status
firefox29 --- affected
firefox30 --- fixed
firefox31 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

References

Details

Attachments

(1 file)

On bug 986190 Mark gave me some preferences to set if you want to get detailed information about sync actions. We should make those available via a debug mode of tps, which could be set with a --debug CLI option.

Here the prefs to set:
pref("services.sync.log.appender.console", "Warn");
pref("services.sync.log.appender.dump", "Error");
pref("services.sync.log.appender.file.level", "Trace");
pref("services.sync.log.rootLogger", "Debug");
pref("services.sync.log.logger.addonutils", "Debug");
pref("services.sync.log.logger.declined", "Debug");
pref("services.sync.log.logger.service.main", "Debug");
pref("services.sync.log.logger.status", "Debug");
pref("services.sync.log.logger.authenticator", "Debug");
pref("services.sync.log.logger.network.resources", "Debug");
pref("services.sync.log.logger.service.jpakeclient", "Debug");
pref("services.sync.log.logger.engine.bookmarks", "Debug");
pref("services.sync.log.logger.engine.clients", "Debug");
pref("services.sync.log.logger.engine.forms", "Debug");
pref("services.sync.log.logger.engine.history", "Debug");
pref("services.sync.log.logger.engine.passwords", "Debug");
pref("services.sync.log.logger.engine.prefs", "Debug");
pref("services.sync.log.logger.engine.tabs", "Debug");
pref("services.sync.log.logger.engine.addons", "Debug");
pref("services.sync.log.logger.engine.apps", "Debug");
pref("services.sync.log.logger.identity", "Debug");
pref("services.sync.log.logger.userapi", "Debug");
pref("services.sync.log.appender.file.logOnSuccess", true);
Oh, what i missed is that all of those prefs should be set set to 'Trace'. Chris, is that correct? I asked because I don't really see a difference between Debug and Trace, when I run tps.
Flags: needinfo?(ckarlof)
Please drop my last question. Not sure why but something was badly cached locally. When I switched the tps test to execute, I get the full trace now.
Flags: needinfo?(ckarlof)
Attached patch Debug mode v1Splinter Review
Attachment #8398801 - Flags: review?(jgriffin)
Comment on attachment 8398801 [details] [diff] [review]
Debug mode v1

Review of attachment 8398801 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm
Attachment #8398801 - Flags: review?(jgriffin) → review+
https://hg.mozilla.org/mozilla-central/rev/6b52fdd7619b
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8398801 [details] [diff] [review]
Debug mode v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): None
User impact if declined: None, but helps sync automation in debugging failures
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): None
String or IDL/UUID changes made by this patch: None
Attachment #8398801 - Flags: approval-mozilla-aurora?
Blocks: 990755
Attachment #8398801 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.