Closed Bug 989449 Opened 8 years ago Closed 8 years ago

Dropmarker corners do not have border-radius on Windows 7, Vista and XP

Categories

(Firefox :: Theme, defect)

31 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 --- verified
firefox30 --- verified
firefox31 --- verified

People

(Reporter: thalesplsantos, Assigned: ntim)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Australis:P3-])

Attachments

(2 files)

Attached image bug.png
Dropmarker buttons are lacking the 2px border-radius in topright and bottomright corners.
Mike, any chance this is because of the recent fix for open menu buttons?
Flags: needinfo?(mdeboer)
I'm pretty sure this is a regression, just not sure from when...
Whiteboard: [Australis:P3]
Whiteboard: [Australis:P3] → [Australis:P3-]
I noticed this bug on Windows XP as well.
Assignee: nobody → ntim007
Status: NEW → ASSIGNED
Summary: Dropmarker corners do not have border-radius → Dropmarker corners do not have border-radius on Windows 7, Vista and XP
Attached patch Patch v1Splinter Review
Can someone test this patch for me ?
Attachment #8398907 - Flags: review?(mdeboer)
Comment on attachment 8398907 [details] [diff] [review]
Patch v1

Review of attachment 8398907 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM! No side-effect, tested on Win 8, 7 & XP.
Attachment #8398907 - Flags: review?(mdeboer) → review+
Keywords: checkin-needed
Whiteboard: [Australis:P3-] → [Australis:P3-][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/74d802ab25c3
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3-][fixed-in-fx-team] → [Australis:P3-]
Target Milestone: --- → Firefox 31
Comment on attachment 8398907 [details] [diff] [review]
Patch v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: Missing round corners
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): Low risk
String or IDL/UUID changes made by this patch: None
Attachment #8398907 - Flags: approval-mozilla-beta?
Attachment #8398907 - Flags: approval-mozilla-aurora?
Attachment #8398907 - Flags: approval-mozilla-beta?
Attachment #8398907 - Flags: approval-mozilla-beta+
Attachment #8398907 - Flags: approval-mozilla-aurora?
Attachment #8398907 - Flags: approval-mozilla-aurora+
Keywords: checkin-needed
Mike, last I knew, your team was still handling the Australis uplifts. Can you please get this landed on Aurora/Beta?
Flags: needinfo?(mdeboer)
Keywords: checkin-needed
The border-radius is now correctly displayed on Windows 7 32bit, Windows 7 64bit, Windows Vista 32bit and Windows XP 32bit using:
- latest Nightly build - 20140407030203,
- latest Firefox Aurora build - 20140407004002 and
- Firefox 29 beta 6 - build ID: 20140407135746.
You need to log in before you can comment on or make changes to this bug.