Closed Bug 989592 Opened 10 years ago Closed 10 years ago

Rendering failure with Chrome and IE providing acceptable result

Categories

(Core :: Graphics, defect)

7 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox28 --- affected
firefox29 --- affected
firefox30 --- affected
firefox31 --- affected
firefox-esr24 --- affected

People

(Reporter: mohammadi.hr, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

129.23 KB, application/zip
Details
Attached file problem.zip
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140127194636

Steps to reproduce:

Tried surfing this page:
http://ganjoor.net/ferdousi/shahname/forood/sh1/


Actual results:

Firefox (Windows, 27.0) fails to render it correctly, the page is Persian, but you do not need to know Persian to see the issue, scroll down to the bottom to see what's wrong


Expected results:

Visit the page with IE and chrome to see acceptable result,
I may change the page structure within next days, weeks and months, so I've attached current page source (sh1.htm in zip file attached)
Could you please paste "Graphics" section of Help > "Troubleshooting Information"?
Flags: needinfo?(mohammadi.hr)
(In reply to Alice0775 White from comment #1)
> Could you please paste "Graphics" section of Help > "Troubleshooting
> Information"?


Graphics
Adapter Description	NVIDIA GeForce GT 630M
Adapter Drivers	nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM	2048
Device ID	0x0de9
DirectWrite Enabled	false (6.2.9200.16492)
Driver Date	11-8-2011
Driver Version	8.17.12.8580
GPU #2 Active	false
GPU Accelerated Windows	0/1 Basic
Vendor ID	0x10de
WebGL Renderer	Google Inc. -- ANGLE (NVIDIA GeForce GT 630M Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	false
AzureCanvasBackend	skia
AzureContentBackend	cairo
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Flags: needinfo?(mohammadi.hr)
I can reproduced with HWA off on 


Regression window with force HWA turned off(m-c hourly):
Works:
http://hg.mozilla.org/mozilla-central/rev/dad825159748
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110527 Firefox/7.0a1 ID:20110527011902
Fails:
http://hg.mozilla.org/mozilla-central/rev/04e8d0b481bc
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110527 Firefox/7.0a1 ID:20110527081111
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dad825159748&tochange=04e8d0b481bc
Regressed by:
Bug 562746 - Update cairo to 1.10
Blocks: 562746
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Version: 27 Branch → 7 Branch
Err.
I can reproduced with HWA off.
Alice: This seems to be fixed on trunk (but not in ff32). Can you confirm this ?
Component: General → Graphics
Flags: needinfo?(alice0775)
(In reply to Matthias Versen [:Matti] from comment #5)
> Alice: This seems to be fixed on trunk (but not in ff32). Can you confirm
> this ?
Yes, I can confirm it is fixed.

No longer reproduce on Firefox33b7, Aurora34.0a2 and nightly35.0a1.
Flags: needinfo?(alice0775)
Thank you very much Alice !
marking wfm
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: