Closed Bug 989596 Opened 7 years ago Closed 7 years ago

Styling for menu buttons (type=menu-button) in Menu Panel is messed up in Firefox 29.0 Beta 3

Categories

(Firefox :: Theme, defect)

29 Branch
x86_64
Windows 8
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: dw-dev, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140327113732

Steps to reproduce:

Started Firefox 29.0 Beta 3 and opened Menu Panel.


Actual results:

The styling of menu buttons (type=menu-button) in the Menu Panel is messed up.  This affects both of my add-ons (Print Edit and Tile Tabs) that use this type of menu button.  Please see attached screen shot.

In Firefox 29.0 Beta 1 and Aurora 30 and Nightly 31, these buttons are styled correctly.


Expected results:

The styling should remain as it was in Firefox 29.0 Beta 1.
Attachment #8398905 - Attachment description: Incorrect styling of menu buttons (e.g. Print Edit) → Incorrect styling of menu buttons in Menu Panel (e.g. Print Edit)
Component: Untriaged → Theme
I am pleased to report that this is NOT a bug in Firefox 29.0 Beta 3.

The problem is caused by the 'KeeFox' add-on applying an insufficiently specific CSS rule to its menu buttons.

I will contact the KeeFox add-on developers to ask them to resolve this issue.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
It's possible Firefox's rule was overly specific so please let us know if that's the case. I'm going to go out on a limb and guess it involves :not(#…).
KeeFox's offending rule is at line 58 in keefox.css :

.toolbarbutton-menubutton-button
{
	-moz-box-orient: horizontal !important;
	padding: 0px 3px !important;
}

As written, this rule will apply to all menu buttons in all add-ons in all locations (toolbar, menu panel, etc), and needs to be made specific to the KeeFox menu buttons.
You need to log in before you can comment on or make changes to this bug.